2000 S/E A/c cuts off - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Everything Electrical & Electronic Have an electrical problem? Lighting, Alternators, gauges, DIC, HUD, etc? Post it here. Please post Audio problems in the Audio forum, and Engine control problems in the appropriate Mechanical forum for your year.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-29-2004, 08:22 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2004
Location: Philadelphia suburbs
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Havisman2000 is on a distinguished road
Default 2000 */E A/c cuts off

2000 */E with no climate control, just the push button type of controls. The A/C compressor has shut off, and stayed off, on me twice in the 3 weeks I've has the car. Both time are on the road, not stopped. The A/C gets cold, about 40 degrees F according to my A/C thermometer. So I think the system is charged enough. The A/C button stays lit on the dash, but no A/C. Could it be a high pressure switch? I've swapped relays in the fuse panel after the problem went away the first time, but the problem is back. Just as mysteriously the A/C compressor comes back on. Any thoughts???
Thanks
Johnny
Havisman2000 is offline   Reply With Quote
Old 06-29-2004, 09:15 PM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Yeah, you may want to have the pressures checked in the system to see if they are OK.
fuddyduddy121 is offline   Reply With Quote
Old 06-30-2004, 02:06 AM   #3
Senior Member
True Car Nut
 
Join Date: Jun 2003
Location: Purgatory
Posts: 6,313
Thanks: 0
Thanked 0 Times in 0 Posts
PontiacDad is on a distinguished road
Default

Once engaged, the compressor clutch will be disengaged for the following conditions:

Throttle position is 100%
A/C Pressure is more than 2968 kPa (430 psi)
A/C Pressure is less than 255 kPa (35 psi)
Engine coolant temperature (ECT) is more than 121C (250F)
Engine speed is more than 5000 RPM
Transmission shift
PCM detects excessive torque load
PCM detects insufficient idle quality
PCM detects a hard launch condition
PontiacDad is offline   Reply With Quote
Old 07-01-2004, 08:25 PM   #4
Junior Member
Thread Starter
 
Join Date: Jun 2004
Location: Philadelphia suburbs
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Havisman2000 is on a distinguished road
Default

Thanks, at least I have a place to start. I'll check the 134a level and go from there.

Thanks,
Johnny
Havisman2000 is offline   Reply With Quote
Old 07-08-2004, 08:13 PM   #5
Junior Member
Thread Starter
 
Join Date: Jun 2004
Location: Philadelphia suburbs
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Havisman2000 is on a distinguished road
Default

I had a friend use his scan tool and found code Po530- A/C refrigerant pressure sensor circuit. Looks like the high pressure switch is bad.
Havisman2000 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
95 SE intermittently cuts off triple18 1992-1999 10 08-07-2007 12:40 PM
car cuts off while driving bigdawg56 2000-2005 3 05-27-2006 05:42 PM
Car cuts off while driving after dash lights go out chilump 1992-1999 5 06-02-2005 06:48 PM
Car cuts off...Turn the wheel and car starts up 95BonnevilleSESC 1992-1999 2 02-20-2004 02:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.