Turn Signal Stops working - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-18-2014, 12:31 AM   #11
LA1
Member
Posts like a V-Tak
Thread Starter
 
LA1's Avatar
 
Join Date: May 2013
Location: east coast
Posts: 99
Thanked 7 Times in 6 Posts
LA1 is on a distinguished road
Default

I was looking at the schematics that chevy82 posted, looks like in the hazard flasher there is "logic" that is probably what is going bad. and i just had the dash off last summer.
LA1 is offline   Reply With Quote
Old 10-18-2014, 10:23 AM   #12
Senior Member
Posts like a Turbo
 
chevy82's Avatar
 
Join Date: Jan 2014
Location: Missouri
Posts: 396
Thanked 99 Times in 84 Posts
chevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of lightchevy82 is a glorious beacon of light
Default

chevy82 is offline   Reply With Quote
Old 10-28-2014, 10:52 AM   #13
Junior Member
Posts like a Ricer Type-R
 
adderallcake's Avatar
 
Join Date: Oct 2014
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
adderallcake is on a distinguished road
Default

My 2001 impala did the same thing. I replaced the hazard switch and it solved the problem. You have to take the plastic piece that stretches across the front of the dash off to change it other than being a little awkward not hard to do. There are a lot of screws stretching across the entire dash but its simple. Once you have the plastic piece off it is as easy as unplugging the old switch and plugging the new one in.
adderallcake is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Left Turn signal not working(switch) ? Zombie Buick 5 06-20-2014 09:40 AM
turn signal not working help? andre_f 1987-1991 4 04-11-2013 09:43 AM
Code 43 turn off on stops and sometimes high idle callenge 1992-1999 2 04-01-2009 01:58 PM
Overdrive sometimes....stops working...? Cortexburn 1992-1999 9 08-20-2007 03:17 AM
turn signal arm is loose and high beams wont turn on!! artofwar215 1992-1999 2 03-16-2007 09:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.