Help with 2004 Danali motor problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-11-2012, 02:53 PM   #1
nas
Junior Member
Thread Starter
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
nas is on a distinguished road
Default Help with 2004 Danali motor problem

I am new to forums, but cannot seem to figure out the problem or a solution. I have a Chevy truck with a 2004 Danali motor. The motor sudden lost ALL oil pressure. i have removed and checked the oil filter and pan for metal, there is none. The feeder valve is clear of debris, the cam-shaft is in tack but still no oil pressure. Has anyone heard of this happening before that can give me some insight as to what else to check or what could be the problem?
nas is offline   Reply With Quote
Old 01-11-2012, 03:02 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

did the engine start knocking, cut off or anything like that or just the gauge. trying to figure out if you really have no oil pressure or the gauge sender or wiring maybe bad. how many miles?
jwfirebird is offline   Reply With Quote
Old 01-11-2012, 03:28 PM   #3
nas
Junior Member
Thread Starter
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
nas is on a distinguished road
Default

no noise, just suddenly no oil pressure. Not sure how many miles on the motor. I just replaced my old, original motor with this one for more hp
nas is offline   Reply With Quote
Old 01-11-2012, 03:33 PM   #4
Senior Member

True Car Nut
 
sseidriver97's Avatar
 
Join Date: Mar 2010
Location: Portage mi
Posts: 7,124
Thanked 3 Times in 3 Posts
sseidriver97 is on a distinguished road
Default

i would check the connection at the OP sender.And if connection is good it could possibly be your guage cluster acting up.i would hook and oil pressure tester to the engine itsself and check.The guage clusters in you year are known to have issues.
sseidriver97 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Drive it till the motor blows or spend the money to fix the motor problem DeathDealer General GM Chat 18 08-04-2012 04:41 PM
Can a'92 ssei motor be replaced by a'92 sse motor instead? Chiefjaybird 1992-1999 3 01-20-2008 10:05 AM
2004 blower motor HSKR 2000-2005 2 10-15-2007 11:11 AM
Swapping out motor to a Monte Motor, couple ???s STWater 1992-1999 13 01-20-2007 11:48 AM
Blower Motor Issues - Dead Motor??? corder13 1992-1999 10 02-14-2006 12:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.