89 Beretta intermittent no start - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-22-2014, 02:47 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Uncle Jim is on a distinguished road
Default 89 Beretta intermittent no start

I have an 89 Beretta GT w/2.8. (Daughter'* school car) always starts when cold. After warm up it may or may not start. No codes set when checking ALDL (diagnostic mode). With engine running ALDL shorted (field serv mode) get fast serv eng soon blink, then slow blink, then constant on. Fuel pressure 44 ign on car off. 39 car running. No spark when cranking and no start. Tach in instrument cluster goes below 0 RPM when cranking. I don't have a SCAN tool or OBD 1 tester. Just a paper clip to short ALDL. Any ideas on where to look for this gremlin?
Thanks, Jim
Uncle Jim is offline   Reply With Quote
Old 02-22-2014, 10:35 PM   #2
Senior Member
Posts like a Northstar
 
1REDCAV's Avatar
 
Join Date: Aug 2010
Location: Mesa, AZ
Posts: 577
Thanked 5 Times in 5 Posts
1REDCAV is on a distinguished road
Default

I'd probably check the ignition module (front of engine, towards the bottom). I used to have an '89 Corsica, and, had the no spark when cranking/no start issue.
1REDCAV is offline   Reply With Quote
Old 02-23-2014, 10:02 AM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

could be crank position sensor too, it will have the same symptoms. the ckp is on the back of the engine though, you can try heating the icm with a heat gun gently to see if it quits it not its likely the ckp
jwfirebird is offline   Reply With Quote
Old 02-23-2014, 11:33 PM   #4
Junior Member
Thread Starter
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Uncle Jim is on a distinguished road
Default

Thanks for the replies Bill & Justin. I replaced the ICM today and couldn't even get a cold start with the new one. Put the old one back on and it cranked right up. Taking the new one back to parts store tomorrow to have it tested. They tested the old one today (cold) and it tested good. If I had any hair, I'd be pullin' it out!
Uncle Jim is offline   Reply With Quote
Old 02-24-2014, 02:05 AM   #5
RPH
Member
Posts like a V-Tak
 
Join Date: Jan 2012
Location: Dayton Ohio
Posts: 41
Thanks: 0
Thanked 6 Times in 5 Posts
RPH is on a distinguished road
Default

GM Modules always test "good" when cold, unless completely fried. Sometimes having them "tested" at a parts store is like giving a open book GED test at a methadone clinic.
RPH is offline   Reply With Quote
Old 02-24-2014, 05:35 AM   #6
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 338 Times in 301 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Welcome to the forum Jim!
Sure would be nice to find some one with an OBD1 Scanner and obtain the stored codes!
Does Auto Zone have a OBD1 scanner available?
Does this help at all? http://www.obd-codes.com/faq/read-gm...codes-free.php

Last edited by Soft Ride; 02-24-2014 at 05:47 AM.
Soft Ride is offline   Reply With Quote
Old 02-24-2014, 08:15 AM   #7
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

you dont want a aftermarket icm, you would be better with a junk yard gm one if you dont want to pay for a new one. sometimes rock auto has decent prices on delphi or delco ones. i agree with the test being useless though, unless you try heating it up with a heat gun or something
jwfirebird is offline   Reply With Quote
Old 02-24-2014, 11:17 AM   #8
Senior Member
Posts like a Supercharger
 
Join Date: Aug 2013
Posts: 174
Thanked 7 Times in 5 Posts
tsaw5500 is on a distinguished road
Default

you can always test your icm with a test light if you can find the ground wire.your path of completion is through the ground side. so maybe do this while heating the icm.
tsaw5500 is offline   Reply With Quote
Old 02-24-2014, 11:22 AM   #9
Senior Member
Posts like a Supercharger
 
Join Date: Aug 2013
Posts: 174
Thanked 7 Times in 5 Posts
tsaw5500 is on a distinguished road
Default

Quote:
Originally Posted by tsaw5500 View Post
you can always test your icm with a test light if you can find the ground wire.your path of completion is through the ground side. so maybe do this while heating the icm.
test light should flash increasingly with engine rpm
tsaw5500 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Chevrolet Beretta GT Parts car for sale in New york! unbelievableny For Sale or Trade 7 10-15-2016 09:42 PM
Beretta Help? Damemorder Lounge 3 02-11-2007 01:54 AM
Supercharger swap to a beretta. chevyboy572 Lounge 14 11-19-2006 06:35 PM
Help PLease with Chevy Beretta problem..1 coil not firing! 95neongirl Lounge 3 04-29-2004 01:50 PM
95 Beretta Z26 jasons92bonne General GM Chat 15 05-22-2003 01:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.