08 Impala bad MPG - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Chevrolet When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-16-2014, 02:14 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
DANMC99 is on a distinguished road
Default 08 Impala bad MPG

I have a 2008 Chevy Impala LT with a 3.5l.
I have 83,000 miles. At about 80,000 miles, the display
went from 26.3 MPG to 20.9. There are no problems and the car runs fine.
The only reason I noticed was went I filled the tank and the mileage till empty went from 425 to 360.
Anyone have any ideas?
Thanks,
Dan
DANMC99 is offline   Reply With Quote
Old 02-16-2014, 04:05 PM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Welcome to the Forum Dan! There are so many factors about MPG to consider.
In general Mpg will vary based on users speed/city or hwy, heavy or light foot driving, mountain or level road conditions, complete state of tune, clean oil, proper tires & inflation, & removing excess weight in trunk or heavy passengers... LOL.
At 80,000 miles new spark plugs and air filter/ full tune up should be considered if one has not been performed. Other things I do to improve mileage are clean or service the throttle body. I also over inflate my tires by 3psi to get better mileage as well, based on door stickers recommendations. I also look for symptoms of brake drag and wheel bearings as possible causes of poor mileage if all the other things are up to speed.
Idle times =0 mpg and cold weather warm up times wont help either. It takes longer for car to warm up as well.

Last edited by Soft Ride; 02-16-2014 at 04:08 PM.
Soft Ride is offline   Reply With Quote
Old 02-16-2014, 09:08 PM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

could have gotten some bad gas. thats about what mine got when i put e85 in it, try getting gas somewhere else and checking the other things art suggested
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bad, bad, bad, bad vibrations.... SilverSleeper8704 2000-2005 11 07-30-2010 06:42 AM
Anyone have an Impala or Impala service manual 92BonneSE Lounge 7 05-28-2007 01:53 AM
The MPG Post to end all MPG Posts mkaake 1992-1999 24 05-05-2005 03:25 AM
BAD one liners. Bad, really really bad, but still funny. BonnieBrougham Lounge 3 12-16-2004 06:38 PM
did tune up and still getting bad gas mpg L27Buick 1992-1999 6 05-06-2004 06:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.