05 escalade wont start - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Cadillac When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-22-2011, 03:30 PM   #1
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
hatrock is on a distinguished road
Default 05 escalade wont start

I have an 05 escalade esv,6.0 . I have fuel pressure at the rail. It starts with starter fluid, but dies. If I press the gas pedal it dies immediately.
hatrock is offline   Reply With Quote
Old 05-22-2011, 03:37 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Does it fire and then die, or does it just crank with no fire at all?

If it'* starting with starter fluid, then it sounds like you have spark, and you have pressure at the rail. That leaves the fuel injectors. Check the fuel injectors fuse. Also, do you have a security light on your dash? What is it doing? Could be a VATs issue. Try a different key. This at least gives you a place to start. I'll poke threw my service manual and see what I can find.
Danthurs is offline   Reply With Quote
Old 05-22-2011, 03:41 PM   #3
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

OK, I see you have a immobilizer, have you changed or added keys?
Danthurs is offline   Reply With Quote
Old 05-22-2011, 03:43 PM   #4
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
hatrock is on a distinguished road
Default

I'll check my injector fuse. security light is not flashing,but i'll try another key.
hatrock is offline   Reply With Quote
Old 05-22-2011, 03:46 PM   #5
BANNED
Posts like a Supercharger
 
Join Date: Aug 2009
Location: Wahpeton, North Dakota
Posts: 183
Thanks: 0
Thanked 0 Times in 0 Posts
zigger21 is on a distinguished road
Default

It sounds like its a fuel pump problem, if you can start it with starter fluid then dies it seems like your not getting enough fuel PSI.
zigger21 is offline   Reply With Quote
Old 05-22-2011, 03:49 PM   #6
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

You can also use a NOID tester. A place like autozone will know what that is. It will test your injectors to see if they are pulsing, it'* easy to use. If no pulse, then check fuse, if that'* good it could be a bad crank position sensor.
Danthurs is offline   Reply With Quote
Old 05-22-2011, 03:50 PM   #7
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Quote:
Originally Posted by zigger21 View Post
It sounds like its a fuel pump problem, if you can start it with starter fluid then dies it seems like your not getting enough fuel PSI.

That is a good point, the OP stated he had pressure at the rail. Guess we should ask how much pressure. 10psi wont cut it. 48-50 is what I believe it should be.
Danthurs is offline   Reply With Quote
Old 05-22-2011, 03:52 PM   #8
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
hatrock is on a distinguished road
Default

I changed the fuel pump, still no help.
hatrock is offline   Reply With Quote
Old 05-22-2011, 03:56 PM   #9
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
hatrock is on a distinguished road
Default

55 psi at the rail.
hatrock is offline   Reply With Quote
Old 05-22-2011, 03:59 PM   #10
Junior Member
Thread Starter
 
Join Date: May 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
hatrock is on a distinguished road
Default

My emission light comes on periodically, but seems to reset.
hatrock is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2008 Escalade Remote Start..Heat on? Bengal313 Cadillac 2 11-14-2013 05:14 PM
1994 bonneville-wont start, wont run backwoodsfab 1992-1999 0 10-09-2008 07:27 PM
Wicked A$$ Escalade Bonneville92V688 Your Other Rides: Pics & Videos 10 03-06-2007 12:34 AM
Me Wont ooo ooo Me Wont!!! bandit Your Other Rides: Pics & Videos 4 06-18-2006 02:09 AM
new escalade sqela Lounge 2 11-19-2005 01:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.