Turn signals - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-13-2015, 04:13 AM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Mar 2011
Posts: 103
Thanked 8 Times in 7 Posts
cliff will become famous soon enough
Default Turn signals

Turn signals quite working on my 1999 buick lesabre, I exchanged the flasher twice and the turn signal fuse, checked the bulbs as well, I have no blinking on the left or right, front or back all are dead, emergency flasher works though, I have brake lights as well, just no turn signals, has anyone had this problem? Please help, thank you. Cliff
cliff is offline   Reply With Quote
Old 12-13-2015, 02:39 PM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Was the fuse blown? Ground problem? Double check your bulbs to ensure they are installed & seated correctly, and making a clean corrosion free contact.
Would be nice to have a signal wiring diagram for your 99 Lesabre, anyone got one?
I also wonder if the turn signal stalk or wiring could be the issue?
Soft Ride is offline   Reply With Quote
Old 12-13-2015, 06:00 PM   #3
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Mar 2011
Posts: 103
Thanked 8 Times in 7 Posts
cliff will become famous soon enough
Default Turn signals

Quote:
Originally Posted by Soft Ride View Post
Was the fuse blown? Ground problem? Double check your bulbs to ensure they are installed & seated correctly, and making a clean corrosion free contact.
Would be nice to have a signal wiring diagram for your 99 Lesabre, anyone got one?
I also wonder if the turn signal stalk or wiring could be the issue?
Fuse was not blown, but I put in a new one as a process of elimination, it really has me torked off, I'm so mad I don't think I spelled torked right! Thanks for your reply. I did find a Web site called trouble shoot my vehicle .com, he has a series of test that I can do, hopefully I can get it figured out, I need to get some wire piercing probes so I can run test to see if I'm getting power to the turn signal switch and to the flasher
cliff is offline   Reply With Quote
The Following User Says Thank You to cliff For This Useful Post:
Soft Ride (12-13-2015)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Windshield Wipers wont turn off, no Turn Signals, door lock won't work, etc methatswho Pontiac 3 03-15-2015 09:26 PM
side mirror turn signals big coop General GM Chat 8 05-09-2003 12:16 PM
Tinted Rear-Turn Signals BonneAlien Your Ride: GM Pictures & Videos 11 04-07-2003 11:35 AM
check out my custom side turn signals (NOT RICEY) S1ofDSS Your Ride: GM Pictures & Videos 14 03-22-2003 04:03 AM
Fog Lights Blink Like Turn Signals? CDecker Performance, Brainstorming & Tuning 10 01-30-2003 06:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.