traction controle and abs light codes - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-28-2013, 06:02 PM   #1
Junior Member
Thread Starter
 
earnies2's Avatar
 
Join Date: Nov 2013
Location: Boston MA
Posts: 2
Thanked 0 Times in 0 Posts
earnies2 is on a distinguished road
Default traction controle and abs light codes

Hello and hope you can help...bought a 99 Regal gs with 78k on it the ABS and traction control light were on when i bought it... I needed to change the */c coupler(it was noisey) and also rebuilt (brushes and v/regulator) the altonator while i had it off... traction light not on now just ABS light i read the codes they are U1040,P1602and B1001 also no dome light, I read your post about the Ground buss and i can not find them i took off the sill strips there is a ground wire with a bolt to the inner sill no corrosion on it and i looked in the harness and coul'nt find the groung buss strip some help would be great I hate any lights on in the dash ....thanks
earnies2 is offline   Reply With Quote
Old 11-29-2013, 03:12 PM   #2
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Sounds like a grounding issue, but not necessarily the buss. More than likely its a ground for the brake control module. That B1001 code is odd though. Have you recently installed a new body control module?

Strange as it may sound, the first thing I would do is get the battery load tested. Even though your problems are likely related to a bad ground connection, there have been cases where some of your symptoms are related to a poorly performing battery. It'* hard to diagnose electrical issues when the battery itself isn't up to spec.
2kg4u is offline   Reply With Quote
The Following User Says Thank You to 2kg4u For This Useful Post:
earnies2 (11-29-2013)
Old 11-29-2013, 10:00 PM   #3
Junior Member
Thread Starter
 
earnies2's Avatar
 
Join Date: Nov 2013
Location: Boston MA
Posts: 2
Thanked 0 Times in 0 Posts
earnies2 is on a distinguished road
Default

Quote:
Originally Posted by 2kg4u View Post
Sounds like a grounding issue, but not necessarily the buss. More than likely its a ground for the brake control module. That B1001 code is odd though. Have you recently installed a new body control module?

Strange as it may sound, the first thing I would do is get the battery load tested. Even though your problems are likely related to a bad ground connection, there have been cases where some of your symptoms are related to a poorly performing battery. It'* hard to diagnose electrical issues when the battery itself isn't up to spec.
thanks for the reply....I checked all the grounds in the engine bay and added another ground to the EBCM and nothing changed i also did the front brakes and replaced the hubs in the front(caliper was seised and berring was bad) no change..i replaced the rear pads and all the brake lines no change until i did the *,c coupler and the brushes and regulator in the altonator than the only change was the traction light went out but the ABS light is still on...I meeterd the wires to the front sensors and with the wheels turing i show voltage so i know i'm good in the front,,,i need to do the rear than i will know the rear sensors are good....i am baffled at the U1040 (no comunication code)..I will load test the battery and let you know the results thanks again for the reply...I am a heavy equipment mechanic and fixing cars is sooo different....
earnies2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1998 Catera - Check Engine Light, ABS Light and TC light on lucille2 Cadillac 2 02-10-2011 11:58 AM
ABS light on, cannot read ABS codes?! B4CTROOPER 2000-2005 1 01-04-2010 06:53 PM
ABS/Traction light on...but i still have ABS ptrfair 2000-2005 0 12-11-2007 08:33 PM
abs light and traction off light are on silentfrwy 1992-1999 9 09-28-2004 04:51 PM
ABS and TRACTION CONTROL light stays on kerker 1992-1999 11 05-13-2003 10:23 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.