Replaced Hubs on 2000 Buick now ABS is on constantly - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-30-2015, 02:40 AM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mrsjones1001 is on a distinguished road
Default Replaced Hubs on 2000 Buick now ABS is on constantly

My ABS light would come on when going through a puddle or when it was wet out. Shop told me I need to replace hubs as the sensor is part of it. So I bought new hubs and my mechanic dad changed both. Now when I go to drive home as soon as I started moving and I pressed on the brakes the ABS instantly kicked in and then the light came on and brakes as usual. It Is on constantly now What might this be? TIA

Last edited by Mrsjones1001; 08-30-2015 at 02:41 AM.
Mrsjones1001 is offline   Reply With Quote
Old 08-30-2015, 10:24 AM   #2
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Quote:
Originally Posted by Mrsjones1001 View Post
My ABS light would come on when going through a puddle or when it was wet out. Shop told me I need to replace hubs as the sensor is part of it. So I bought new hubs and my mechanic dad changed both. Now when I go to drive home as soon as I started moving and I pressed on the brakes the ABS instantly kicked in and then the light came on and brakes as usual. It Is on constantly now What might this be? TIA
We have no idea what your mechanic did or didn't do right. We suggest you take it back to him.
Mike is offline   Reply With Quote
Old 08-30-2015, 10:43 AM   #3
Junior Member
Thread Starter
 
Join Date: Aug 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mrsjones1001 is on a distinguished road
Default

Quote:
Originally Posted by Mike View Post
We have no idea what your mechanic did or didn't do right. We suggest you take it back to him.
As I specified in my post it was my dad who replaced them and he'* been a mechanic for over 30 years. Everything went smooth and put together as it should. Could it possibly be a pinched wire or maybe just a faulty hub?
Mrsjones1001 is offline   Reply With Quote
Old 08-30-2015, 01:56 PM   #4
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Then its suggested that someone put a computer on it that can read ABS codes.
Mike is offline   Reply With Quote
Old 08-30-2015, 01:58 PM   #5
Junior Member
Thread Starter
 
Join Date: Aug 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mrsjones1001 is on a distinguished road
Default

Quote:
Originally Posted by Mike View Post
Then its suggested that someone put a computer on it that can read ABS codes.
Thank you! That was my next step.
Mrsjones1001 is offline   Reply With Quote
Old 09-01-2015, 10:58 PM   #6
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,148
Thanked 783 Times in 612 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

That should have been your first step....

The shop that told you it was hubs, did they do any tests?
Tech II is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2001 4.0l Aurora - ABS and Trac Off light constantly on LAurora Oldsmobile 5 02-12-2014 02:52 AM
replaced hubs now a new noise three days later gmfreak 2000-2005 11 08-28-2007 10:46 PM
Climate Control constantly reading 76* ext. temp ozarkirish87 2000-2005 8 07-15-2006 10:46 PM
Cooling fan stay on constantly. Please help! floorwax8 1992-1999 4 10-11-2004 12:13 AM
rotors constantly warping jayare627 2000-2005 7 03-06-2004 08:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.