Regal Whoas - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-16-2011, 03:54 PM   #1
STM
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2011
Location: rockwell north carolina
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
STM is on a distinguished road
Default Regal Whoas

first a little background on the car had it for 2 months ran like a champ no problems what so ever... now this is what i got going on my wife tells me on her way to school fri. that going up the exit ramp it starts to miss then clears up as she takes off at the top of the ramp, makes it to school ,she leaves school drives about 5 miles gets back onto the interstate and it starts doing it agin she stays in the right lane makes it home but complains to me its running like crap... so i check the car over .. no check engine light... but some things i noticed as i got to looking real good, original coil pack, old wires, old spark plugs, original converter, old looking fuel filter.. so I replace all of them .. runs a little better but still no fix ( LOL the old plugs had a gap of 90th and the coil pack plug connections where corroded so it had to run better! ) so for giggles i decide to run the codes and code 34 came up .. ran a vacuum test with a gauge found that it was a little off so i found the leak ,re did the vacuum test all good, reset the ECM and the code 34 went away ... still not running like it should its still a little hesitant but it gets really bad when the TC locks and it drops to 1500 Rpm at 55 , pull it down into drive up the Rpm a little and it runs better not like it did, but better.. one other thing i noticed was a slight tick in the firewall side of the engine not bad but noticeable when the hood is up......

any ideas would be most helpfull
STM is offline   Reply With Quote
Old 04-16-2011, 04:00 PM   #2
STM
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2011
Location: rockwell north carolina
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
STM is on a distinguished road
Default

lol oops 1993 buick regal GS with a 3.8 tunedport injection!!!
STM is offline   Reply With Quote
Old 04-16-2011, 04:07 PM   #3
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Take a spray bottle with water and mist the plug wires and coils, do this at night and turn off all the lights. Watch for blue flashing. You may have a ground. Also make sure none of the plug wires are touching the O2 sensor wire.
Danthurs is offline   Reply With Quote
Old 04-16-2011, 06:04 PM   #4
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

DTC - 34 MAP sensor circuit error (signal low indicating high vacuum)

you may need a new one.

the tick sounds like ex manifold gasket or where the man meets the y pipe
jwfirebird is offline   Reply With Quote
Old 04-16-2011, 09:41 PM   #5
STM
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2011
Location: rockwell north carolina
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
STM is on a distinguished road
Default

ok danthurs just did the water trick .. no light show... and the O2 wires are not touching the SP wires ..

jwfirebird is the MAP sensor and the MAF sensor one? i cant find a MAP at all ,even when i go to buy one on the net it shows a list of them but when i click on them its not for the 3.8 all are for the 3.1...the 34 code still has not shown its self agin soo i dont know whats happening there...

more info: as i have been driving the car today (mostly back and forth to the part store) I noticed that the gas mileage is now horrible where it has been awesome for a car that size(averages 26 to 27 mpg) could it be possible the O2 sensor is to blame for all this? I did unplug it earlier and it made no differnce on how the engine sounded....perhaps because its not working at all?

by the way thanks for replying to my post you 2
STM is offline   Reply With Quote
Old 04-16-2011, 09:44 PM   #6
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

The O2 could be bad. If it'* never been changed, then it may be a good idea to change it.
Danthurs is offline   Reply With Quote
Old 04-17-2011, 09:42 PM   #7
STM
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2011
Location: rockwell north carolina
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
STM is on a distinguished road
Default

ok changed the O2 sensor it had a white chalk on it seems to run a little better but still not like it was I also changed the engine temp sensor (wow i could smack the engineer who put it there!) I had to take the throttle body off to get to it .. then thats when i noticed there where a few chambers there one large one on top the two side by side directly below .. from the ones below one driped anti freeze on my hand so i wiped the inside with my finger and sure enough there was more there (the bottom right chamber) now this might sound silly but is it supposed to be there? never having worked on one of these i have to ask It'* a tuned port intake if that makes a difference one other thing i pulled the hose of the fuel pressure regulator covered the vacuum hole off on the intake and revved the engine and it did not change how it acted is this too normal?
STM is offline   Reply With Quote
Old 04-17-2011, 09:46 PM   #8
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Not sure I follow what your saying about the ECT sensor, perhaps a picture would help.

As for your FPR, can you smell any gas in the vacuum line?
Danthurs is offline   Reply With Quote
Old 04-17-2011, 11:39 PM   #9
STM
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2011
Location: rockwell north carolina
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
STM is on a distinguished road
Default

the ECT was below the throttle body it was just a pain to get to is all, where the anti freeze was at was in in the manifold behind the TB and no i smell no gas on the vacuum tube leading to the FPR
STM is offline   Reply With Quote
Old 04-17-2011, 11:40 PM   #10
STM
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Apr 2011
Location: rockwell north carolina
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
STM is on a distinguished road
Default

ill post a pic tomorrow
STM is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Charging System/Voltage Whoas llBlazin_llLo 1992-1999 3 05-16-2006 09:18 PM
Tha Regal! 94Regal Your Ride: GM Pictures & Videos 4 04-18-2004 11:38 PM
Finally!!!!!! G-Teched the Regal!! 94Regal Performance, Brainstorming & Tuning 14 04-13-2004 08:44 AM
Buick Regal Replacement.. Custom88 Lounge 8 01-28-2004 10:17 PM
Regal GS VS. GTP Video! GTX COWBOY General GM Chat 25 09-08-2003 10:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:30 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.