motor idles up and down 93 regal 3.1 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-22-2013, 11:43 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
93regal is on a distinguished road
Default motor idles up and down 93 regal 3.1

Motor idles up n down in 500rpm blows black smoke and dies when u put in gear. How many airffliw sensors are I replaced the 2 bolt round one. What else could this be computer? Cat? Any suggestions on what to repair next
93regal is offline   Reply With Quote
Old 07-23-2013, 07:14 AM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,588
Thanked 340 Times in 302 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

The IAC (intake air control) can cause this.Got a photo of what u replaced?
The TPS can cause issues, and the other is the Maf or mass airflow sensor.
Did u have the vehicle scanned for computer codes? Is the check engine light on?
Soft Ride is offline   Reply With Quote
Old 07-23-2013, 09:50 AM   #3
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

What is the "2 bolt round one" you replaced? Was that the Idle Air Control? The would be the first thing I would look at. Next would be the throttle position sensor. Here is a write up on how to test it:

https://www.gmforum.com/trouble-shoo...sensor-279319/

Also, check for any vacuum leaks.
2kg4u is offline   Reply With Quote
Old 07-23-2013, 11:37 AM   #4
Junior Member
Thread Starter
 
Join Date: Jul 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
93regal is on a distinguished road
Default

No codes were shown to last mechanic. He couldn't communicate with comp. He thought that was the issue. If I replace computer is it just plug n play or would it need programming
93regal is offline   Reply With Quote
Old 07-23-2013, 12:18 PM   #5
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Quote:
Originally Posted by 93regal View Post
No codes were shown to last mechanic. He couldn't communicate with comp. He thought that was the issue. If I replace computer is it just plug n play or would it need programming
You'd have to get it programmed to your VIN, but there are some people who sell used PCM'*, and they can flash the VIN to it for you, then send it to you, from there it is pretty much plug and play.
I'm not sure it is the PCM though, is the mechanic using a scanner that can communicate with OBD 1.5?
WilliamE is offline   Reply With Quote
Old 07-23-2013, 03:39 PM   #6
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i think 93 would just be obd1. they had the chips, but if you get a different pcm and put your chip in it that still could be the problem. i would go through the mentioned tests first, pcm is normally last resort and not a very common failure
jwfirebird is offline   Reply With Quote
Old 07-24-2013, 01:45 AM   #7
Senior Member

True Car Nut
 
WilliamE's Avatar
 
Join Date: Jun 2011
Location: VA
Posts: 3,087
Thanked 418 Times in 376 Posts
WilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond reputeWilliamE has a reputation beyond repute
Default

Quote:
Originally Posted by jwfirebird View Post
i think 93 would just be obd1. they had the chips, but if you get a different pcm and put your chip in it that still could be the problem. i would go through the mentioned tests first, pcm is normally last resort and not a very common failure
You're right Justin, my mistake, it was 94' and not 93' when OBD 1.5 came out, that is what I get for posting after being up all night.
WilliamE is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Truck idles rough hesitates and wont stay started sheath GMC/Chevrolet Truck/SUV 2 07-22-2012 11:43 AM
car idles @ 3500 rpm at start and 1900 rpm in drive? 88bonnsse 1987-1991 15 01-27-2008 04:41 AM
stalls & jerks when cold when warmed up idles rough 92olds88royale Oldsmobile 4 02-01-2006 08:09 AM
A rattle when the car idles. Maestro 1987-1991 6 08-20-2005 12:08 AM
93 ssei idles rough mekobes44 1992-1999 4 07-15-2004 11:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:15 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.