Mass air flow sensor 2003 Lesabre - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-14-2016, 11:18 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2015
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
cowboy1611 is on a distinguished road
Default Mass air flow sensor 2003 Lesabre

Getting a code for the Mass air flow sensor, what one is best or worst ?

How finicky are these ?
The only thing I notice is occasionally it bucks when starting from a red light...

It seems to run rough when idling, but it'* always done that (seen another post on that, seems they do that)
cowboy1611 is offline   Reply With Quote
Old 03-14-2016, 12:58 PM   #2
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,855
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Word on the street is that second hand OEM is best. You will want to be sure to match numbers with your current unit.

Aftermarket units typically found at part store chains are typically unreliable.

Also be sure that you have done everything to confirm that yours does in fact need to be replaced. If you tap it with the handle of a screw driver while running and the car reacts to it, then there likely is an issue with it. Also it could be dirty which is an easy fix (They make a product to do just this).

What is the exact code you are getting? I have seen other problems cause MAF related codes while the MAF is still perfectly fine.
rjolly87 is offline   Reply With Quote
Old 03-14-2016, 02:19 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2015
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
cowboy1611 is on a distinguished road
Default

Should have mentioned, but I did clean it with maf cleaner, have had it read several times and codes cleared, they have gone off and on a few times but mostly on.

Don't have the exact #'* but did verify they were for the maf.
cowboy1611 is offline   Reply With Quote
Old 03-14-2016, 02:33 PM   #4
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,855
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Another thing you can do is try running with the MAF unplugged. If the MAF is the cause of the issues, the car typically will run better at that point.

The specific code however is just as important as knowing that it is a MAF related code.

Also if it idles rough, there is usually a reason for it, but the list of possible causes is a mile long.
rjolly87 is offline   Reply With Quote
Old 03-14-2016, 06:13 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2015
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
cowboy1611 is on a distinguished road
Default

Right concerning the long list, I may have mis stated that, I'm not sure that it'* actually idling rough but it does have a vibration like it was...
As a matter of fact, it probably isn't idling rough.

So the only real symptom is the hiccup when starting at a red light or even sometimes when driving.
cowboy1611 is offline   Reply With Quote
Old 03-14-2016, 08:26 PM   #6
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,641
Thanked 995 Times in 772 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

What was the code?
Mike is offline   Reply With Quote
Old 03-15-2016, 11:37 AM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2015
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
cowboy1611 is on a distinguished road
Default

The codes are P0102 and P0172
cowboy1611 is offline   Reply With Quote
Old 03-15-2016, 06:16 PM   #8
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,641
Thanked 995 Times in 772 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

The P0102 is a low frequency code from the MAF sensor. If you already cleaned it with MAF cleaner, just go ahead and replace it. The other code is a RICH Bank 1 code, change the MAF sensor out and clear the codes. Unlikely the 2nd will come back.
Mike is offline   Reply With Quote
Old 03-15-2016, 06:17 PM   #9
Senior Administrator


Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,641
Thanked 995 Times in 772 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Wait, did you clear the codes after cleaning it?
Mike is offline   Reply With Quote
Old 03-18-2016, 01:02 PM   #10
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Nov 2015
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
cowboy1611 is on a distinguished road
Default

Got the codes before cleaning.

Don't remember if they went away after that, but in any case they did come back.

Have had it read a few times and they were cleared, one time even seemed to clear themselves i.e. ce light was on then went off for a bit then back on....
cowboy1611 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
MAF mass air flow, 02 lesabre cowboy1611 Buick 5 12-02-2015 07:26 PM
IAT sensor integrated in Mass Air Flow Sensor? cballweg Bonneville GXP/ Northstar Powered Cars 6 05-04-2006 03:37 AM
Mass Air Flow sensor problem telliot647 1987-1991 33 10-03-2004 10:48 PM
Mass Air Flow sensor=transmission problems? killer_cr80r Lounge 8 06-04-2004 12:53 AM
Mass Air Flow sensor JuanMarco19 1987-1991 2 06-17-2003 03:14 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.