Blinkers are fast and passenger's side is solid - 1999 Buick Century Custom - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-29-2011, 02:54 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Tearitup's Avatar
 
Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Tearitup is on a distinguished road
Question Blinkers are fast and passenger'* side is solid - 1999 Buick Century Custom

Hi again all,

My blinkers have been on the fritz recently. Sometimes when I activate the blinker, either left or right, it will go super fast. The front light does not blink at all but the back blinker does light up regardless of speed. In addition, the passenger'* side front blinker remains lit anytime the key is in the ignition.

Is it trying to tell me something? I cannot find any definite answers to what causes this. Is it the flasher, a bulb, or something else?

Thanks for the help, and sorry if this has been answered somewhere else - I did use the search.
Tearitup is offline   Reply With Quote
Old 07-29-2011, 02:59 AM   #2
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

It might be your bulb. I'd check that first. They're only a couple dollars, so its no big deal if thats your problem or not. It might also be in the multifunction switch..the lever that activates the signal lights, high beams, etc. When I first got my Century, the low beams wouldn't come on, and it turned out to be a problem in the mfs.

Does the front lights work with the drls?
2k2cse is offline   Reply With Quote
Old 07-29-2011, 03:00 AM   #3
Member
Posts like a V-Tak
Thread Starter
 
Tearitup's Avatar
 
Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Tearitup is on a distinguished road
Default

Quote:
Originally Posted by 2k2cse View Post
It might be your bulb. I'd check that first. They're only a couple dollars, so its no big deal if thats your problem or not. It might also be in the multifunction switch..the lever that activates the signal lights, high beams, etc. When I first got my Century, the low beams wouldn't come on, and it turned out to be a problem in the mfs.

Does the front lights work with the drls?
Which bulbs should I be looking at first? Also, what do you mean by DRLS?
Tearitup is offline   Reply With Quote
Old 07-29-2011, 03:04 AM   #4
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

The daytime running lights.. the signal lights in the front.. they stay lit during the day. They are also on when your headlights and park lights are on.
2k2cse is offline   Reply With Quote
Old 07-29-2011, 03:05 AM   #5
Member
Posts like a V-Tak
Thread Starter
 
Tearitup's Avatar
 
Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Tearitup is on a distinguished road
Default

Quote:
Originally Posted by 2k2cse View Post
The daytime running lights.. the signal lights in the front.. they stay lit during the day. They are also on when your headlights and park lights are on.
I will check this out and get back to you.

Thanks so much for your help!
Tearitup is offline   Reply With Quote
Old 07-29-2011, 03:13 AM   #6
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

This is what it should look like during the day:



With the park lights on:



and with the headlights on:




Don't forget to check the bulbs in the cornering lights too. I'm not sure if one of them blows, the signal light for that side would go out too.

If you have any more questions, I can check my car tomorrow.
Attached Thumbnails
Blinkers are fast and passenger's side is solid - 1999 Buick Century Custom-dsc03989a.jpg   Blinkers are fast and passenger's side is solid - 1999 Buick Century Custom-dsc03903et.jpg   Blinkers are fast and passenger's side is solid - 1999 Buick Century Custom-dsc03978g.jpg  
2k2cse is offline   Reply With Quote
Old 07-29-2011, 02:55 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
Tearitup's Avatar
 
Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Tearitup is on a distinguished road
Default

After testing them all today, all of the lights work perfectly, which means something is happening after driving it for a while that causes this to happen. None of the bulbs are blown from what I can tell, so any ideas as to what is causing this? is it the MFS as mentioned?
Tearitup is offline   Reply With Quote
Old 07-29-2011, 03:46 PM   #8
Senior Member
Certified GM nut
 
2k2cse's Avatar
 
Join Date: Jan 2011
Location: Newfoundland, Canada
Posts: 2,112
Thanked 18 Times in 17 Posts
2k2cse has a spectacular aura about2k2cse has a spectacular aura about
Default

It could be the MFS. It might also be a relay or fuse.
2k2cse is offline   Reply With Quote
Old 07-29-2011, 06:10 PM   #9
Senior Member

True Car Nut
 
2kg4u's Avatar
 
Join Date: Sep 2006
Location: Windsor, Ontario / Detroit, Michigan
Posts: 4,804
Thanked 220 Times in 181 Posts
2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of2kg4u has much to be proud of
Default

Other than the side front blinker remaining lit with the key in the ignition, I would be tempted to start by putting in a new flasher. Its a $15 dollar part for your car, and usually the first place I start when having turn signal issues.
2kg4u is offline   Reply With Quote
Old 07-30-2011, 09:31 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
Tearitup's Avatar
 
Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Tearitup is on a distinguished road
Default

I found a new pattern. When I first put the key in the ignition, both of the signal lights are lit, which I am assuming is the daytime running lights. When I use the left blinker, the blinker works and when I disable it, the light remains dim. The passenger'* side blinker still remains lit. Usually, it is after this that the left blinker flashes very quickly, and sometimes it alternates between the left and right signals. It is hard to find consistency in the problem.

Should I replace the flasher? Could that be affecting my daytime running lights?
Tearitup is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Century passenger side inner tie rod issue. NolanSyKinsley Buick 5 12-15-2014 12:17 AM
1999 buick century transmission icehouse1 Buick 2 08-02-2011 09:18 PM
Tearitup's 1999 Buick Century Custom Tearitup Your Ride: GM Pictures & Videos 13 07-18-2011 04:23 AM
1999 Buick Century Custom - Weird Squealing when running A/C Tearitup Buick 18 07-13-2011 11:59 PM
Ford fan new to GM - 1999 Buick Century Tearitup Introductions for new members 7 07-08-2011 08:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.