'88 Century Fuel Pump Issue - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-20-2012, 05:20 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
JB.17 is on a distinguished road
Default '88 Century Fuel Pump Issue

Hi everyone. New From California. I have a 1988 Century 3.8L V6. The problem is the fuel pump won't turn on to prime the system when I turn the key to run and won't run when I turn the ignition over to start. The problem only happens after running the car for a while but a couple of times now it has just stopped while its running. After sitting for a bit to cool off it will start again and run fine. The pump sounds strong when it does run so I don't think that'* the problem. I have replaced the FP relay and the oil pressure switch but am starting to think its a problem with the ECM. The only codes being set are 2&3. Thanks for the help.

Jake
JB.17 is offline   Reply With Quote
Old 10-20-2012, 05:42 PM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

i dont know of a code 2 or 3. as far as the pump check the connector at the pump some times the pump connectors start to get loose or corroded. if you have power and ground through the connection when it * quit then the pump is bad.
jwfirebird is offline   Reply With Quote
Old 10-20-2012, 05:52 PM   #3
Senior Administrator








Certified Car Nut
 
Mike's Avatar
 
Join Date: Jul 2003
Location: Horseheads, NY
Posts: 15,649
Thanked 1,001 Times in 777 Posts
Mike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond reputeMike has a reputation beyond repute
Default

Next time it won't start, have someone bang on the bottom of the fuel tank with a rubber mallet while you crank over the engine. If it fires right up, then its the fuel pump. If its an OEM pump, I'm surprised it has lasted this long.
Mike is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Century passenger side inner tie rod issue. NolanSyKinsley Buick 5 12-15-2014 12:17 AM
2001 Century - PS Pump Mickman Buick 1 03-09-2013 03:20 PM
1998 cadillac fuel pump issue!!! dkbtwoo Cadillac 10 01-15-2013 12:36 PM
'97 Firebird - Fuel Pump Issue! hawaii50 Pontiac 6 06-17-2011 12:06 AM
Fuel Pump issue, & I'm out of Ideas!! ColoBonne 2000-2005 7 01-23-2008 02:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:17 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.