2007 buick lucerne 3.8 random stall - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-13-2017, 04:43 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
1beenzman is on a distinguished road
Default 2007 buick lucerne 3.8 random stall

i have a random stall after long road trips about 238 miles car runs good dosent stall on road . when i get to my destination i unload the car and it sits for a half hour i get in it starts no problem go to a store and when i come out and start the car it stumbles and stalls it did this twice. it fires after that but some times i have to push on the accelerator pedal to get it running .but it dosent do it all the time . im getting fuel pump pressure checked o tuesday
1beenzman is offline   Reply With Quote
Old 11-13-2017, 11:44 PM   #2
Senior Member

Certified GM nut
 
Tech II's Avatar
 
Join Date: Feb 2014
Location: Worcester, Ma.
Posts: 2,106
Thanked 761 Times in 596 Posts
Tech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond reputeTech II has a reputation beyond repute
Default

could be a number of things....dirty throttle body/plate....dirty IAC pintle...bad IAC or harness/wire connection....leaking fuel pressure regulator.....bad MAF or dirty sensor, etc....

Scanned for codes?
Tech II is offline   Reply With Quote
Old 11-21-2017, 09:32 PM   #3
Senior Member
Posts like a Supercharger
 
Join Date: Apr 2015
Posts: 156
Thanked 21 Times in 17 Posts
John01 will become famous soon enoughJohn01 will become famous soon enough
Default

My '01 Le Sabre had the same symptoms. Replacing the 6/3 coil fixed it.

You may be lucky and need only one coil.
John01 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2007 Buick Lucerne transmission model eb-86 Buick 11 01-29-2016 04:49 AM
Heater doesn't heat well - 2007 Buick Lucerne 3800 eb-86 Buick 31 12-20-2015 02:46 AM
Harmonic Balance 2007 Buick Lucerne 3800 series 3 meg Buick 7 02-28-2015 07:24 PM
Help 2007 Buick Lucerne upnorthfever Buick 5 11-25-2013 03:56 PM
2007 Buick Lucerne Super sverd1 General GM Chat 9 04-13-2007 09:11 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.