2003 buick regal instrument panel problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-13-2013, 10:18 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
BrewTown is on a distinguished road
Unhappy 2003 buick regal instrument panel problem

So last week while on the highway my cars instrument panel shut off while driving (as in the fuel gauge, temp gauge, rpm and speed gauge) all shot down as if I shut the car off. Then about a second later it all came on again and car beeped like when you start it up. It didn't shut my engine off or anything just my panel. It did it about 3 times that night then just today it'* done it about 20 sum times and I have no clue what'* up with it. I've had it plugged in to find a problem but couldn't find one. I was told that I should check the fuses cause that may be the problem but it looked like the fuses are good so I have no clue. Any ideas or solutions (also now it'* doing it while I'm driving and while parked!)
BrewTown is offline   Reply With Quote
Old 08-14-2013, 07:21 AM   #2
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

pull the fuse and see if its loose or corroded. find the ground take it apart and clean it. if neither of those try taking the pod out and reinstalling it a couple times, sometimes the connector gets a loose pin. if none of those could be something inside it.
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 Buick Regal Over Heating FiretoFlames Buick 12 01-04-2013 07:37 PM
instrument panel overlay teezer Detailing & Appearance 29 06-06-2006 01:06 AM
Advice on instrument panel 92RI-SE Everything Electrical & Electronic 1 10-14-2004 03:09 PM
Rebuilt Instrument Panel for exchange rcci 1992-1999 2 09-30-2004 11:59 PM
instrument panel lights out ly41181 1992-1999 14 05-13-2003 02:06 PM


Tags
2003, buick, electrical, instrument panel, regal

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:07 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.