01 Buick Century Dash light problem - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Buick When starting new posts, please specify YEAR, MAKE, MODEL, ENGINE type, and whatever modifications you have made.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-15-2014, 11:25 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Fabman is on a distinguished road
Default 01 Buick Century Dash light problem

I have a 01 buick century and the dash light go off once and a while, I checked the fuse and it looks good, any ideas?
Fabman is offline   Reply With Quote
Old 03-16-2014, 06:59 AM   #2
Senior Member
True Car Nut
 
Soft Ride's Avatar
 
Join Date: Jan 2012
Location: BC Canada
Posts: 3,586
Thanked 339 Times in 301 Posts
Soft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud ofSoft Ride has much to be proud of
Default

Welcome to the forum Mitchell!
I'm not overly familiar with the century, however, sometimes it may be a cause of the dimming control switch, or even the dash main bus connector.
When they go off, try moving the dimming control & see if they come back on for starters.
I am sure others may chime in as well....

Last edited by Soft Ride; 03-16-2014 at 07:00 AM.
Soft Ride is offline   Reply With Quote
Old 03-16-2014, 01:30 PM   #3
Senior Member
True Car Nut
 
jwfirebird's Avatar
 
Join Date: Dec 2009
Location: western,ny state
Posts: 9,616
Thanked 563 Times in 481 Posts
jwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond reputejwfirebird has a reputation beyond repute
Default

could be a loose or corroded fuse as well
jwfirebird is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buick Century Limited harmonic balancer problem voxa Buick 2 02-16-2015 05:40 PM
Buick Century Acceleration Problem! bobbi Buick 10 03-18-2014 05:57 PM
94' Buick Century - Shifting Problem fspialek Buick 2 07-15-2013 06:56 PM
1998 Buick Century - air conditioner problem Golf123 Buick 2 06-28-2011 09:07 AM
buick 2003 century interminent problem bigmoe9 Buick 2 08-23-2010 10:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.