DTCs and Hard shifting - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Bonneville GXP/ Northstar Powered Cars Discuss your Bonneville GXP and/or any other Northstar powered Olds or Cadillac... Including the 3.5L Twin Cam V6 (Short Star ) 4.0L and 4.6L Northstar V8's. Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-08-2010, 06:38 PM   #1
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default DTCs and Hard shifting

about 7 or 8 months ago i left my house and while driving to work i noticed that my car was shifting very hard, when i go from 1st to second it feels like someone rear ended me, it happened for a bit and 20 minutes later when i took my car to GM, i shut it off, and when i started it again it was all history and wouldnt happen again
today, i left work for a bit, and when i hit the road, same problem, very hard shifting
i had a SES light on for a week or so but the car was very normal to drive, i never had the chance to scan it, so i just came home and scanned it and the following showed up

[PCM] P0442 - Evaporative Emission (EVAP) System Small Leak Detected (SES) (Old) (History) (Current) (Immature)
[PCM] P0502 - Vehicle Speed Sensor (VSS) Circuit Low Input (Old) (Immature)
[Brake] C1226 - RF Excessive Wheel Speed Variation (History)
[Unknown] P1540 - Air Conditioning (A/C) Refrigerant Overpressure - Air Conditioning (A/C) Disabled (History) (Immature)
[Entertainment] B1004 - Keep Alive Memory (KAM) (History) (Immature)
[Entertainment] B1327 - Device Power Circuit Low (History) (Immature)
[Entertainment] U1255 - Class 2 Communication Malfunction (History) (Current) (Immature)
[Personal Comm.] B2470 - Daytime Running Lamps Fault (History) (Immature)


anything might be related? i doubt it

i shut the car off at a red light, back on right away, problem stayed
i shut the car off for 10 minutes when i got home, started it back again, shes back to normal


any ideas?
SAMzGXP is offline   Reply With Quote
Old 09-08-2010, 06:52 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Hmm, with all those unrelated codes it makes me think there'* a problem with corrosion. Is there a chance things got really wet? Remove the plugs on the PCM and check them for any kind of build up. Clean and reconnect.

The WSS and VSS are very close to each other. Check and clean them as well. Almost seems like you drove threw a deep puddle.
Danthurs is offline   Reply With Quote
Old 09-08-2010, 07:22 PM   #3
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

[Entertainment] B1004 - Keep Alive Memory (KAM) (History) (Immature)
[Entertainment] B1327 - Device Power Circuit Low (History) (Immature)
[Entertainment] U1255 - Class 2 Communication Malfunction (History) (Current) (Immature)
[Personal Comm.] B2470 - Daytime Running Lamps Fault (History) (Immature)

ever since i replaced my HU the above doesnt clear for some reason
i guess its related to it
i tried installing the factory HU back then, it cleared IIRC
SAMzGXP is offline   Reply With Quote
Old 09-08-2010, 09:12 PM   #4
Administratus Emeritus
Certified Car Nut
 
GXP Venom's Avatar
 
Join Date: Jan 2006
Location: Purgatory, Pennsylvania
Posts: 16,538
Thanked 7 Times in 4 Posts
GXP Venom is on a distinguished road
Default

Nothing there about the tranny or TCM. Weird. Maybe the VSS is affecting the TCM?
GXP Venom is offline   Reply With Quote
Old 09-08-2010, 09:17 PM   #5
Senior Member
Posts like a Corvette
 
StealthGXP's Avatar
 
Join Date: Aug 2010
Posts: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
StealthGXP is on a distinguished road
Default

Quote:
Originally Posted by SAMzGXP View Post
[Entertainment] B1004 - Keep Alive Memory (KAM) (History) (Immature)
[Entertainment] B1327 - Device Power Circuit Low (History) (Immature)
[Entertainment] U1255 - Class 2 Communication Malfunction (History) (Current) (Immature)
[Personal Comm.] B2470 - Daytime Running Lamps Fault (History) (Immature)

ever since i replaced my HU the above doesnt clear for some reason
i guess its related to it
i tried installing the factory HU back then, it cleared IIRC
Your HU is wored into the Data Bus... making the car RETARDED !!


My buddys Deville is having the same stupid issues.
StealthGXP is offline   Reply With Quote
Old 09-08-2010, 09:21 PM   #6
Senior Member
Posts like a Corvette
 
StealthGXP's Avatar
 
Join Date: Aug 2010
Posts: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
StealthGXP is on a distinguished road
Default

What is the fluid level like in the trans ?? How is the outer seal on the left front ??? is it leaking ?
StealthGXP is offline   Reply With Quote
Old 09-08-2010, 11:45 PM   #7
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

Quote:
Originally Posted by GXP Venom View Post
Nothing there about the tranny or TCM. Weird. Maybe the VSS is affecting the TCM?
possible, last time didnt scan it and never had a SES light, just a matter of time and it all disappeared
SAMzGXP is offline   Reply With Quote
Old 09-08-2010, 11:50 PM   #8
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

Quote:
Originally Posted by StealthGXP View Post
Your HU is wored into the Data Bus... making the car RETARDED !!
My buddys Deville is having the same stupid issues.
any better way of wiring it? lol
and the HU been in the car for over a year or so now, i doubt its part of the problem
well, i hope not lol

Quote:
Originally Posted by StealthGXP View Post
What is the fluid level like in the trans ?? How is the outer seal on the left front ??? is it leaking ?
last time i check the fluid was over a month or so ago, and it was perfect, as for leaks i dont notice any.
1st time this happened to me months and months 1st thing i did was check the fluid, and again, it wasnt low or overfilled
shifting was horrible throughout the entire RPM range, even shifting at 2500 or 3000RPM you can feel the kick for sure. and when you hit 6 or 7k RPM, its alot worse dh2dh2
SAMzGXP is offline   Reply With Quote
Old 09-08-2010, 11:54 PM   #9
Senior Member
Posts like a Corvette
 
StealthGXP's Avatar
 
Join Date: Aug 2010
Posts: 1,337
Thanks: 0
Thanked 0 Times in 0 Posts
StealthGXP is on a distinguished road
Default

Quote:
Originally Posted by SAMzGXP View Post
any better way of wiring it? lol
and the HU been in the car for over a year or so now, i doubt its part of the problem
well, i hope not lol



last time i check the fluid was over a month or so ago, and it was perfect, as for leaks i dont notice any.
1st time this happened to me months and months 1st thing i did was check the fluid, and again, it wasnt low or overfilled
shifting was horrible throughout the entire RPM range, even shifting at 2500 or 3000RPM you can feel the kick for sure. and when you hit 6 or 7k RPM, its alot worse dh2dh2
you have no trans codes...

try a flush and filter, or at least get in there and check things out
StealthGXP is offline   Reply With Quote
Old 09-08-2010, 11:58 PM   #10
Senior Member
True Car Nut
Thread Starter
 
SAMzGXP's Avatar
 
Join Date: Mar 2009
Location: Fort crack homie
Posts: 2,894
Thanks: 0
Thanked 0 Times in 0 Posts
SAMzGXP is on a distinguished road
Default

Quote:
Originally Posted by StealthGXP View Post
you have no trans codes...

try a flush and filter, or at least get in there and check things out
car is still under warranty for another year and a half, i hope it happens again and we can figure it out before its over
theres no point in checking it out here, they will tell me "we can not duplicated the problem at the time being" and charge me $195.00 an hour for labour
yes its $195.00 an hour at GM in Fort Crap
SAMzGXP is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4T65E hard shifting when driven hard pontiacandryan 1992-1999 14 06-29-2009 05:25 PM
Transmission Shifting Hard- 4t65e SuperchargedFury 2000-2005 10 11-09-2004 03:07 PM
Transmission Shifting Hard - 4t65e SuperchargedFury 1992-1999 2 09-03-2004 11:54 AM
Hard shifting thoughout all gears after the range senor..... killer_cr80r Lounge 5 06-16-2004 02:51 AM
Hard shifting into Park Jim W Bonneville GXP/ Northstar Powered Cars 6 06-07-2004 09:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:31 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.