Pioneer System Sounding Like Crap - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 07-20-2004, 12:44 AM   #1
G2T
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2004
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
G2T is on a distinguished road
Default Pioneer System Sounding Like Crap

I have a nice Pioneer Head Unit One of the newer ones with the flip down face plate. And i just got new pioneer 6x8s for the rear both 110 wattts a piece. I have stock fronts.
Now I listen to just about everything. I crank it up without the LOUD settin on and almost everything will distort. I put it on the Powerfull Equilizer Setting and my rear speakers sound like complete **** so do the fronts. And I thought this was normal untill i got subs. No this is bulshit I was in my friends monte carlo today (old school 7 and he has an alpine system no subs but all speakers replaced and it has some damn nice bass and no distortion from any speaker i could hear and we had it damn loud. Everything was clear. How can I get this with speakers and a head unit. If it means differnet speakers there ebay for that. Please help me yall.
And on a futher note how to I attach my head unit metal harness thing the damn thing sides out every time i accelerate. Its annoying as sht.
G2T is offline   Reply With Quote
Old 07-20-2004, 01:53 AM   #2
Senior Member
Posts like a Corvette
 
Join Date: Jan 2004
Location: Mastic, NY NEBF2 Survivor
Posts: 1,567
Thanks: 0
Thanked 0 Times in 0 Posts
Garb is on a distinguished road
Default

you need to pull into a parking lot, crank it, and mess with your equalizer in your deck. i ahve alot of faith in pioneer. pioneer 6500 deck and pioneer 6x9 4 ways. and with subs your speakers should not be handling any bass at all. mess with everything, the stock speakers inthe front could be holding you back also.
Garb is offline   Reply With Quote
Old 07-20-2004, 09:36 AM   #3
Senior Member
Posts like a Corvette
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

IT sounds like you need to leave the loudness and the eq off, and turn it down a little
jachin is offline   Reply With Quote
Old 07-20-2004, 11:33 AM   #4
G2T
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2004
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
G2T is on a distinguished road
Default

I do have the loud setting off sry for the misconception. And I dont have subs. I was hoping to get fairly good bass speaker wise with pioneers. And I guess I have to screw with my equilizer as you guys said and then replace the stock shitty **** speaker?
G2T is offline   Reply With Quote
Old 07-20-2004, 11:34 AM   #5
Senior Member
True Car Nut
 
Join Date: Jan 2004
Location: Chicago,IL MWBF '04 SURVIVOR MWBF '05 SURVIVOR Napa Manager
Posts: 3,955
Thanks: 0
Thanked 0 Times in 0 Posts
Kennginn is on a distinguished road
Default

i agree with the eq u might have to jus mess with a mix cd for about 30 - 45 mins and set everything up
Kennginn is offline   Reply With Quote
Old 07-20-2004, 03:15 PM   #6
Senior Member
Certified GM nut
 
Join Date: Apr 2003
Location: Davison,Michigan
Posts: 1,867
Thanks: 0
Thanked 0 Times in 0 Posts
russianpolarbear is on a distinguished road
Default

You could have one or more of the wires crossed going to the speakers.
russianpolarbear is offline   Reply With Quote
Old 07-20-2004, 06:13 PM   #7
Senior Member
Posts like a Corvette
 
Join Date: Sep 2003
Location: springfield il
Posts: 1,369
Thanks: 0
Thanked 1 Time in 1 Post
jachin is on a distinguished road
Default

That has to do with phase. That wouldnt be causing the problem
jachin is offline   Reply With Quote
Old 07-20-2004, 09:21 PM   #8
Junior Member
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default

if this is in your Taurus then that'* the problem right there. The mounting locations suck. a friend I used to have had a 91 taurus and no matter what he put in that car the speakers sounded like absolute crap! make sure that the speakers are sealing good against the surface they're mounting to.. also, make sure there aren't a lot of openings that are letting air escape. For good bass response you need things to be air tight.
Custom88 is offline   Reply With Quote
Old 07-21-2004, 12:23 AM   #9
G2T
Member
Posts like a V-Tak
Thread Starter
 
Join Date: May 2004
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
G2T is on a distinguished road
Default

Got new kenwoods and retuned system like yall said sounds exelent next is subs with a wave box enclosurew which i am now in love with.
G2T is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New Pioneer to replace old Pioneer head unit *Now with pics! Bugsi Audio (and aftermarket electronics) 8 05-18-2006 03:03 PM
Here is an idea for better sounding speakers max on this Audio (and aftermarket electronics) 9 02-27-2004 05:40 PM
Need help with Pioneer deck in Bose system ASAP OLBlueEyesBonne Audio (and aftermarket electronics) 17 01-10-2004 10:38 AM
Strange sounding problem MoparMitch 2000-2005 3 07-07-2003 04:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:13 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.