HELP -NO SOUND!!! Kenwood KDC-MP528. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 11-25-2005, 02:32 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default HELP -NO SOUND!!! Kenwood KDC-MP528.

I just picked one of these up for a steal this morning at a Black Friday sale.
They're going for $150'ish on ebay including shipping. Paid a good bit less than that for mine.

Anyhow, what do you guys think of this model? Anyone have any experience with this same model?
OLBlueEyesBonne is offline   Reply With Quote
Old 11-25-2005, 02:52 PM   #2
Senior Member
True Car Nut
 
Join Date: Jun 2004
Location: Rochester, NY (college)
Posts: 6,182
Thanks: 0
Thanked 0 Times in 0 Posts
corvettecrazy is on a distinguished road
Default

not too bad...

what else do you plan to run with it?
corvettecrazy is offline   Reply With Quote
Old 11-25-2005, 03:04 PM   #3
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Quote:
Originally Posted by corvettecrazy
not too bad...

what else do you plan to run with it?
My current Alpine Type * 5.25" 2-way'* in the front along with BOSE tweeters, and Infinity Reference 6x9 3-ways in the rear.
I have my Infinity 12" DVC sub and Orion cheater amp (600x1 @ .5 ohm load), but I don't think I'll put the sub/amp back in as the amp needs to be hard wired and I like to be able to remove it easily at the track.
OLBlueEyesBonne is offline   Reply With Quote
Old 11-25-2005, 03:16 PM   #4
Senior Member
True Car Nut
 
Join Date: Jun 2004
Location: Rochester, NY (college)
Posts: 6,182
Thanks: 0
Thanked 0 Times in 0 Posts
corvettecrazy is on a distinguished road
Default

Quote:
Originally Posted by OLBlueEyesBonne
Quote:
Originally Posted by corvettecrazy
not too bad...

what else do you plan to run with it?
My current Alpine Type * 5.25" 2-way'* in the front along with BOSE tweeters, and Infinity Reference 6x9 3-ways in the rear.
I have my Infinity 12" DVC sub and Orion cheater amp (600x1 @ .5 ohm load), but I don't think I'll put the sub/amp back in as the amp needs to be hard wired and I like to be able to remove it easily at the track.
as long as the amp is easy to remove from what ever you mount it too, taking it out is pretty simple. Assuming you mount it to the sub box, you then have to remove 4 wires...not that hard.
corvettecrazy is offline   Reply With Quote
Old 11-25-2005, 06:29 PM   #5
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Ok. THIS DECK IS REALLY PEEVING ME NOW!!!!!!!! I'm supposed to be going to the Casino with my GF (her B-day today) and it'* 120 miles one-way, and I'm leaving in 15 minutes).
Deck came with paper on it that said the radio comes from the factory in DEMO ON mode. Turn to DEMO ON mode.
I tested the radio a little before turning the Demo mode off. When I did it immediately stopped giving any volume.
I for the life of me CANNOT figure out how to get the volume back on. I switched it back to Demo On mode and that didn't help.
I found a function that said V-OFF, but can't get it to say V-ON.
OLBlueEyesBonne is offline   Reply With Quote
Old 11-25-2005, 07:48 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default

V-Off means Voice'* off....Or close too

Eliminates most of the vocals out of the track to simulate an instrumental.

What I would do....is disconnect power to the deck for a few min, then start over and try again.....

I've never been too fond of Kenwood products......Fair warning lol.
LakevilleSSEi is offline   Reply With Quote
Old 11-26-2005, 08:08 PM   #7
Senior Member
True Car Nut
Thread Starter
 
Join Date: Dec 2002
Location: Sauk Centre, MN
Posts: 5,458
Thanks: 0
Thanked 0 Times in 0 Posts
OLBlueEyesBonne is on a distinguished road
Default

Ended up taking the Explorer to the Casino. JBL Concert sound is dang nice, but the lack of a CD player was annoying.

Took Nates advice and disconnected it today. Hooked it back up and it functions as well as I could hope for -not nearly as powerful or clean of a sound as the stock 7-band CD deck, but it looks cool with that "L67 Supercharged 3800" shift ****, and it goes well with my them of switching from green/gold to green/chrome/gold SLX theme.
OLBlueEyesBonne is offline   Reply With Quote
Old 11-26-2005, 09:25 PM   #8
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default

Quote:
Originally Posted by OLBlueEyesBonne
Ended up taking the Explorer to the Casino. JBL Concert sound is dang nice, but the lack of a CD player was annoying.

Took Nates advice and disconnected it today. Hooked it back up and it functions as well as I could hope for -not nearly as powerful or clean of a sound as the stock 7-band CD deck, but it looks cool with that "L67 Supercharged 3800" shift ****, and it goes well with my them of switching from green/gold to green/chrome/gold SLX theme.
Should wire up a battery disconnect switch.....easier then disconnecting the battery cable.

You're prolly gonna be doing that often....LOL
LakevilleSSEi is offline   Reply With Quote
Old 11-26-2005, 09:30 PM   #9
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

I've got the 828 and it'* great. Sounds like you were playing in one of the 6 million menus and turned something off.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Kenwood eXcelon KDC-X693 opinions. jcrazyjj Audio (and aftermarket electronics) 22 01-26-2010 12:36 AM
FS: Kenwood KDC-X459 Head Unit xDRx Lounge 6 10-18-2007 09:27 PM
Kenwood Christmas (Need Help w/ Install) Merlin 91/97 Audio (and aftermarket electronics) 26 01-09-2005 12:51 PM
Kenwood Upgrades Merlin 91/97 Audio (and aftermarket electronics) 3 03-15-2004 08:00 PM
Kenwood 6x9's and HU bonnie94ssei Audio (and aftermarket electronics) 15 11-19-2003 02:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:20 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.