CD player won't play - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 04-17-2005, 08:35 PM   #1
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: May 2003
Location: New Hampshire
Posts: 1,305
Thanks: 0
Thanked 0 Times in 0 Posts
Hailey is on a distinguished road
Default CD player won't play

Hey guys...I am having a little problem with my CD player. Today I gave the old Bonnie his Spring detailing, and everything was fine before I started. Unfortunately I left the radio on for most of the time, and didn't run the car much so I killed my battery. I was at the in-laws' and my father-in-law is a mechanic so he had one of those things that you can use to jump a car (I can't remember what they are called)...the professional ones. He jumped me and the car started right up. The problem is, after it started, the CD player said, "Check CD" and wouldn't spit it out. I pressed the eject button a couple times and it came out, but it made a strange little sound as it ejected (a bit of a scraping/squeeky sound). I tried putting the CD back in, and it would take it (no more wierd noises) but then it would just do exactly the same thing again (including not automatically ejecting the CD after the error). The radio is fine.

Okay, so I know nothing about electronics. I read the manual and it said that humidity could do that so I figured maybe it was too humid in the car after shampooing the carpet (but I only did the driver and passenger front areas). I took out the CD and opened the windows, and let it dry for about 1/2 hour, but that either wasn't enough time or that isn't it. I know I didn't spray anything near it so it isn't really wet (I always spray the paper towels, not the surface). The other thing that crossed my mind is that the jump did something...or maybe a combination of factors caused this...I just don't know.

Does anyone have any ideas? I would go crazy if my CD player was broken so I'd really appreciate any help you can offer figuring it out. Thanks!
Hailey is offline   Reply With Quote
Old 04-17-2005, 11:37 PM   #2
Senior Member
Posts like a Turbo
 
Join Date: Feb 2005
Location: Buffalo, NY
Posts: 311
Thanks: 0
Thanked 0 Times in 0 Posts
ForeverSilent004 is on a distinguished road
Default

disconnect the negative battery terminal for 5-10 minutes. ittl reset the radio. see if thatl work
ForeverSilent004 is offline   Reply With Quote
Old 04-17-2005, 11:38 PM   #3
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by ForeverSilent004
disconnect the negative battery terminal for 5-10 minutes. ittl reset the radio. see if thatl work
make ssure you know your theftlock code or have it disabled first
1993 SLE is offline   Reply With Quote
Old 04-17-2005, 11:43 PM   #4
Senior Member
Posts like a Turbo
 
Join Date: Feb 2005
Location: Buffalo, NY
Posts: 311
Thanks: 0
Thanked 0 Times in 0 Posts
ForeverSilent004 is on a distinguished road
Default

oh, i dont think my radio had them fancy-schmancy gizmos
ForeverSilent004 is offline   Reply With Quote
Old 04-18-2005, 11:19 AM   #5
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: May 2003
Location: New Hampshire
Posts: 1,305
Thanks: 0
Thanked 0 Times in 0 Posts
Hailey is on a distinguished road
Default

Thanks...I'll try that. And I don't have to worry about the theftlock because it hasn't been set since I bought the car used. Who knows, maybe it has dried out and works by now anyway (my husband has the car today so I'll have to ask him when I see him).
Hailey is offline   Reply With Quote
Old 04-20-2005, 11:21 AM   #6
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: May 2003
Location: New Hampshire
Posts: 1,305
Thanks: 0
Thanked 0 Times in 0 Posts
Hailey is on a distinguished road
Default

Hey, it spontaneously started working before I had a chance to try that. I guess it must have been moisture that finally dried up after all. Thanks for your help anyway though...I'm just thrilled it'* working.
Hailey is offline   Reply With Quote
Old 04-20-2005, 12:50 PM   #7
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

glad to here that is back and functioning
1993 SLE is offline   Reply With Quote
Old 04-22-2005, 04:18 PM   #8
Senior Member
Posts like a Corvette
Thread Starter
 
Join Date: May 2003
Location: New Hampshire
Posts: 1,305
Thanks: 0
Thanked 0 Times in 0 Posts
Hailey is on a distinguished road
Default

Thanks! I'm just so happy it is working.
Hailey is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need play by play of rear rotor/pad install torero500 2000-2005 2 04-25-2008 10:43 PM
Cool both of my cd player play overburned cd Masterbm Lounge 1 05-26-2006 09:20 AM
BFest 2004 Play By Play BonnieBrougham Lounge 13 07-23-2004 12:06 AM
Cd player wont play okredek Audio (and aftermarket electronics) 1 03-09-2004 10:39 PM
Cassette player(stock) to CD player 0Tick General GM Chat 6 12-02-2002 01:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.