battery keep going low - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


Audio (and aftermarket electronics) This is your place for alarms, remote starters, to brag about your system, exaggerate your db levels, or simply ask questions for stock or aftermarket audio. No Flames! (except from roasted amps)

Reply
 
 
 
Thread Tools Search this Thread
Old 04-22-2005, 10:32 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Grand Rapids, Mi
Posts: 3,244
Thanks: 0
Thanked 0 Times in 0 Posts
L27Buick is on a distinguished road
Default battery keep going low

well i unplugged my amp to see if it killing my battery, well since i unplugged it my battery fine . but when the amp is plugged in and the car is off the amp is also off. so whats killing my battery? if it matters my remote for the amp is tied with the power antenna cuz their is only 1 remote wire on the harness and i have a power antenna so i tired them both together.
L27Buick is offline   Reply With Quote
Old 04-22-2005, 11:12 PM   #2
Sol
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 8,909
Thanks: 0
Thanked 0 Times in 0 Posts
Sol is on a distinguished road
Default

Do you have the ELC feature?
Sol is offline   Reply With Quote
Old 04-22-2005, 11:22 PM   #3
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Grand Rapids, Mi
Posts: 3,244
Thanks: 0
Thanked 0 Times in 0 Posts
L27Buick is on a distinguished road
Default

nope if i did i would have the inflater thing right?
L27Buick is offline   Reply With Quote
Old 04-22-2005, 11:23 PM   #4
Sol
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 8,909
Thanks: 0
Thanked 0 Times in 0 Posts
Sol is on a distinguished road
Default

Yes. Usually that'* the culprit, but not in your case.

Is your battery just old?
Sol is offline   Reply With Quote
Old 04-22-2005, 11:24 PM   #5
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Grand Rapids, Mi
Posts: 3,244
Thanks: 0
Thanked 0 Times in 0 Posts
L27Buick is on a distinguished road
Default

nope i bought it last weekend cuz i had the same problem.
L27Buick is offline   Reply With Quote
Old 04-23-2005, 12:04 AM   #6
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by L27Buick
nope i bought it last weekend cuz i had the same problem.
ok where is your power lead for your amp kit, did you mess with any of the leads on the battery?? does your battery have top posts??? take a voltmeter and see the drain off the pos and neg cables
1993 SLE is offline   Reply With Quote
Old 04-23-2005, 02:30 AM   #7
Senior Member
Posts like a Corvette
 
Join Date: Jul 2004
Location: Bolingbrook, IL Location: Clarkston, MI
Posts: 1,256
Thanks: 0
Thanked 0 Times in 0 Posts
llBlazin_llLo is on a distinguished road
Default

Try keeping an amp hooked up but not turning on the radio. Maybe your amp is drawing so much power that your alt is not charging you battery?
llBlazin_llLo is offline   Reply With Quote
Old 04-23-2005, 09:27 AM   #8
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Location: Grand Rapids, Mi
Posts: 3,244
Thanks: 0
Thanked 0 Times in 0 Posts
L27Buick is on a distinguished road
Default

thats the problem when the amp is hooked up and the car will it overnight and or the day it will act like it has a low battery when u start it. but i unhooked the amp for the week to see what will happen and its been fine.
L27Buick is offline   Reply With Quote
Old 04-23-2005, 09:31 AM   #9
Senior Member
True Car Nut
 
Join Date: Oct 2003
Location: Pittsburgh, Pa.
Posts: 7,551
Thanks: 0
Thanked 0 Times in 0 Posts
SSsuperchargedEi is on a distinguished road
Default

describe what its doing to make you think the battery is draining...
SSsuperchargedEi is offline   Reply With Quote
Old 04-23-2005, 10:51 AM   #10
Senior Member
True Car Nut
 
toastedoats's Avatar
 
Join Date: Sep 2004
Location: Fitchburg Ma _ToastedRice_
Posts: 6,837
Thanks: 0
Thanked 0 Times in 0 Posts
toastedoats is on a distinguished road
Default

Quote:
Originally Posted by L27Buick
nope if i did i would have the inflater thing right?
i know that my 2000 has ELC but no inflator
toastedoats is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How to keep your low beams on with your highs (quad beam) LeSabreUltra Everything Electrical & Electronic 40 03-03-2010 09:37 PM
New to the forum...'98 SSEI wol would like to keep both the high and low beams on gage Everything Electrical & Electronic 3 11-22-2009 03:10 AM
need help asap.. need to keep powered when removing battery Custom88 Everything Electrical & Electronic 10 06-22-2004 11:58 PM
how to keep the low beams on when the high beams go on? NERV Everything Electrical & Electronic 26 06-16-2004 07:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:03 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.