Won't go past 3500RPM - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-28-2008, 07:53 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Attleboro, MA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Luniew is on a distinguished road
Default Won't go past 3500RPM

Hello Everyone my first post and I'm asking for help,

Over the weekend I was driving on the highway under heavy acceleration car started hesitating and SEL came on flashing. The car has been making a rattling noise for the past few months when under light/heavy acceleration to about 3000RPM, and at start

I got some codes pulled at AutoZone 0404 and 0440 the EGR was replaced today with no improvement. Looked at all vacuum lines and they look good.
The 0440 code has been on for few months, I just didn't get a chance to troubleshoot it yet, the 0404 code is new.

My best guess is to look at the cat next, could a bad cat throw a EGR code?

The Boni has 104K on it, plugs and wires were replaced about 6K a go.

Please any suggestions, comments.

Thanks
Tom
Luniew is offline   Reply With Quote
Old 07-28-2008, 08:19 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I'm wondering if your in limp home mode. Any other codes?
Danthurs is offline   Reply With Quote
Old 07-28-2008, 08:36 PM   #3
Member
Posts like a V-Tak
 
Join Date: Jul 2008
Location: Harrison, OH / West Harrison, IN
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
FoxXx96SE is on a distinguished road
Default

Quote:
Originally Posted by Danthurs View Post
I'm wondering if your in limp home mode. Any other codes?

thats what it sounds like to me, was she smoking abnormally?


the codes come up to be

0404 EGR open position performance
0440 EVAP system fault

a little more on the EVAP fault from cardealerforums

A P0440 fault is general Evap system fault and could be as much as leaving
your gas cap loose. ( but you probably wouldn't admit to it anyhow.)
Assuming that the gas cap is tight and not hanging off there are a couple of
hoses that dry rot and could cause this fault to set, One is under the
vehicle at the Canister and the other under the air cleaner. There is also a
switch called the NVLD (Natural Vapor Leak Detection) that is supposed to
see a closed (sealed) input when the evaporative system is sealed and no
leaks are present. If this switch goes bad it will also set this fault code.
A scan tool would be needed to see this input. With mileage this vehicle has
I would lean towards the hoses being cracked causing your problem. If you
cant visual see any cracks in any hoses you may have to have a smoke test
performed along with a scan tool connected to verify the fault and diagnose
the problem.

Last edited by FoxXx96SE; 07-28-2008 at 08:37 PM.
FoxXx96SE is offline   Reply With Quote
Old 07-28-2008, 08:40 PM   #4
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Attleboro, MA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Luniew is on a distinguished road
Default

Would a transmition in a limp home mode throw a code? AutoZone only got those two above.
Transmition fluid level is good.
Would unpluging battery get rid of the limp home mode?
I unpluged the battery after changing the EGR and no change.
No smoke

Tom

Last edited by Luniew; 07-28-2008 at 08:42 PM.
Luniew is offline   Reply With Quote
Old 07-28-2008, 08:43 PM   #5
Member
Posts like a V-Tak
 
Join Date: Jul 2008
Location: Harrison, OH / West Harrison, IN
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
FoxXx96SE is on a distinguished road
Default

if your car is in limp mode, it doesnt have anything to do with the transmission, what it does is limit the brain box to a low enough RPM to get the car either home, or to a repair shop before the issues get too severe. i would check what i listed above, as well as for any odors/smoke in the exhaust to see if it is a catalytic converter that fried, but i dont think i have ever seen a cat throw the ECU into limp mode...
FoxXx96SE is offline   Reply With Quote
Old 07-28-2008, 11:35 PM   #6
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Attleboro, MA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Luniew is on a distinguished road
Default

I took the her for another drive, its getting worse its getting very jumpy at 1500RPM and when at WOT its working louder than usual and struggles. To me it seams like there'* a restriction somewhere in the exhaust...but I will now for sure tomorrow or Wednesday the car is going to a garage.
I will keep you guys updated.
Luniew is offline   Reply With Quote
Old 07-28-2008, 11:39 PM   #7
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Perhaps the MAP sensor. When my wifes went out it ran rough, didn't want to shift, had no power.
Danthurs is offline   Reply With Quote
Old 07-28-2008, 11:47 PM   #8
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Attleboro, MA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Luniew is on a distinguished road
Default

Did she get a code for the map or no code? I had mine checked and I only got an egr and evap codes.
Luniew is offline   Reply With Quote
Old 07-28-2008, 11:55 PM   #9
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I don't recall the codes I pulled but none of them were for the MAP. codes don't always tell you what the problem is. I was putting codes on my car for my tranny when it was a cracked EGR tube.
Danthurs is offline   Reply With Quote
Old 07-29-2008, 12:27 AM   #10
Junior Member
Thread Starter
 
Join Date: Jul 2008
Location: Attleboro, MA
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Luniew is on a distinguished road
Default

I will look in to that before the car goes to the garage.
Luniew is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 won't rev past 2k in gear, and runs rough MasterX964 Pontiac 9 02-10-2015 07:29 AM
1994 Chevy lumina euro 3.1 liter won't rev up past 2000 rpms ericthegr8 Chevrolet 3 05-30-2013 07:48 AM
Car won't rev past 3700 RPMS idling, or in gear! - *FIXED* Mortehl 1992-1999 2 10-16-2005 12:17 PM
Won't rev past 3500rpm while in gear Merlin 91/97 1987-1991 13 11-10-2003 07:03 PM
Want to go past 2000RPM? Hahaha... lazicn 1992-1999 0 07-06-2003 12:30 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.