Stalling after warmed up. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-06-2009, 08:31 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
4carb's Avatar
 
Join Date: Jun 2007
Location: S. Maine
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
4carb is on a distinguished road
Default Stalling after warmed up.

2000 SSei. Stalls after warmed up, 10-15 minutes. No codes, no engine light. Yes, engine light works. I replaced the crank and cam sensors along with the Ignition module. I cleaned out the MAF. Plugs are A/C. Will start back up after it cools off. I noticed nothing odd/unusual with the coil packs when removed. Plug wires are good. Fuel pressure is over 40 psi, even when stalling occurs. Getting spark. Help. lol

Anything I should look out for?
4carb is offline   Reply With Quote
Old 07-06-2009, 09:20 PM   #2
Member
Posts like a V-Tak
Thread Starter
 
4carb's Avatar
 
Join Date: Jun 2007
Location: S. Maine
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
4carb is on a distinguished road
Default

Went out and tapped on the MAF while running, started running funny. Tapped it again and it stalled. Hard to start. Got it running after a bit. I than unplugged the MAF and it ran. Plugged it back in and it died. Replace the MAF?
4carb is offline   Reply With Quote
Old 07-06-2009, 11:47 PM   #3
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

Quote:
Originally Posted by 4carb View Post
Replace the MAF?
Yepper!
Purplehazeir is offline   Reply With Quote
Old 07-07-2009, 11:14 AM   #4
Member
Posts like a V-Tak
Thread Starter
 
4carb's Avatar
 
Join Date: Jun 2007
Location: S. Maine
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
4carb is on a distinguished road
Default

Thanks Kevin.

I ordered a reman GM MAF last night.
4carb is offline   Reply With Quote
Old 09-30-2009, 02:16 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
4carb's Avatar
 
Join Date: Jun 2007
Location: S. Maine
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
4carb is on a distinguished road
Default

The GM reman crapped out Monday. Wifey left the house, calls about 5 minutes later saying the car is acting up. I threw my suit of shinning armor on to rescue her. It was acting like it did the last time we got some bad gas. I ended up towing the car home with my Jeep. This time, the engine light actually came on, wooohooooo! Makes it much easier when the car tells me whats wrong. Hooked up my scan tool and showed the MAF. I took the engine cover off the top, and the cover to the MAF was just about completely off. I'm sure water and crud has gotten in it. After calling GM and hearing their $359 price.... I called Napa and got a NEW one from them for about half the price. I hope this one lasts longer than 2.5 months......
4carb is offline   Reply With Quote
Old 09-30-2009, 03:34 PM   #6
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

BTW, you can unplug the maf and drive the car. The airflow will calculate off speed, throttle position etc from tables in the pcm. Most likely the car will be running rich, but it will and can run with the maf unhooked.

That way you don't have to tow
BillBoost37 is offline   Reply With Quote
Old 09-30-2009, 03:44 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
4carb's Avatar
 
Join Date: Jun 2007
Location: S. Maine
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
4carb is on a distinguished road
Default

Thank you Bill. I didn't suspect the MAF, so I didn't bother. I had thought of disconnecting it, than thought it wasn't it as it seemed to be more of a fuel/skipping issue. Acted different from the first time the MAF went out. Not to mention it'* under the engine cover and I had no tools to get the nut off that holds the cover on. lol The cover is now sitting in my garage.......
4carb is offline   Reply With Quote
Old 09-30-2009, 09:46 PM   #8
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

There'* a chance it'* not the MAF, check the wires on the plug. Had a grand prix here about a month ago with MAF problems. Turned out to be a loose wire in the plug.
Danthurs is offline   Reply With Quote
Old 10-04-2009, 10:35 AM   #9
Member
Posts like a V-Tak
Thread Starter
 
4carb's Avatar
 
Join Date: Jun 2007
Location: S. Maine
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
4carb is on a distinguished road
Default

That was the first thing I checked after pulling the code. I thought the MAF should last much longer than a few months.... Defective reman I guess. :(
4carb is offline   Reply With Quote
Old 10-04-2009, 10:59 AM   #10
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

There is always a chance the sensor is bad out of the box. There are several tests for the MAF in the testing area of the tech info.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
92 oldsmobile 88 stalling when cold fine when warmed up 92olds88royale Oldsmobile 153 11-15-2011 08:46 AM
Car hestitant to start after previously been warmed up ROBZ 2000-2005 4 03-18-2009 08:00 PM
stalls & jerks when cold when warmed up idles rough 92olds88royale Oldsmobile 4 02-01-2006 08:09 AM
0-85 vid...with warmed up torque convertor... harofreak00 Your Other Rides: Pics & Videos 35 08-29-2005 09:16 PM
Surge problem with my SSEi only when warmed up. RyanSSEi 1992-1999 2 12-20-2002 11:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:07 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.