Stability Control System-ABS-Traction Control - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 01-16-2007, 09:55 PM   #11
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Dec 2002
Location: Bellbrook, Ohio
Posts: 547
Thanks: 0
Thanked 0 Times in 0 Posts
compyelc4 is on a distinguished road
Default

Craziest thing today. The car is due to go into the garage tomorrow for code reading...RIGHT? Well, today all console lights have been normal. Kinda P_sses me off. No Stability Control warning. No AntiLock light. Trac light is ON as it should be. WTF Are those dudes going to be able to read any codes? Kinda makes me want to hold up on the diagnosis, take a chance and order the Steering Position Sensor at $44. WHAT WOULD YOU DO?
compyelc4 is offline   Reply With Quote
Old 01-16-2007, 10:29 PM   #12
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

The codes should be stored in the history file. They should still be able to see what they were.

Before deciding one way or another if you want to replace the steering position sensor, read this, then decide.

http://www.alldatadiy.com/alldata/AF...3452/121072070
Archon is offline   Reply With Quote
Old 01-16-2007, 11:01 PM   #13
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Dec 2002
Location: Bellbrook, Ohio
Posts: 547
Thanks: 0
Thanked 0 Times in 0 Posts
compyelc4 is on a distinguished road
Default

Thanks archon.

Kina makes you go hmmmmmmmmmmmmmmmmmmmmmmmmmmmm.
compyelc4 is offline   Reply With Quote
Old 01-20-2007, 01:26 AM   #14
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Dec 2002
Location: Bellbrook, Ohio
Posts: 547
Thanks: 0
Thanked 0 Times in 0 Posts
compyelc4 is on a distinguished road
Default

Followup- I cancelled out the code check with the dealer. I'm playing my hand. Stabilitrac system has been behaving for 5 days now. The only thing different is that the rain has stopped and all is cold and dry. Now I'm thinking that moisture may have got into one or more of my ABS hub connections. This would explain why I was getting Trac and Anti-lock warning lights for a few days while very wet out (after replacing both front hubs), but it does not explain why I no longer get the Stability Control System warning on the DIC. Heck I was getting that light several times per day, and it was getting worse by the week, until 5 days ago when the Trac and Anti-Lock lights started behaving themselves. As you may recall the Stability Control System warning light began shortly after lubing the intermediate shaft about a year ago. Funny thing, I relubed it a few days before the Stabilitrac system self-corrected! BTW, I lubed the shaft by coating the shaft "universal" with spray lithium grease as someone here suggested. It took a couple of days but the grease must have worked in somehow and all is very quiet and smooth "for now".

Tomorrow I'm going to have a look at those ABS hub connections to see if I can figure out why I might be getting moisture in there.
compyelc4 is offline   Reply With Quote
Old 01-20-2007, 10:14 AM   #15
Senior Member
Posts like a Turbo
 
Join Date: Jan 2007
Location: South Bend, IN
Posts: 223
Thanks: 0
Thanked 0 Times in 0 Posts
BoneZ is on a distinguished road
Default

When i got my car, i was getting the Stability Control on my screen, and i was getting the Brake light, ABS light and Trac light all coming on at the same time. I also knew i had at least one bad wheel bearing that was bad, so i replaced both front wheel bearing hubs. After replacing the hubs, the brake lights/trac light went away for a very short time, but came back. Went and had all 4 rotors turned because one back rotor was pretty warped. After having all 4 rotors turned and front wheel bearing hubs replaced, i never saw any message or light again.

I drive on the highway to and from work everyday and at those speeds with a bad rotor or hub bearings, you are tripping certain sensors. Midas had the nerve to tell me that he'* never seen a warped rotor trip sensors like that and whoever told me that didn't know what they were talking about. Midas also wanted to charge $320 to turn all 4 rotors. I was like, hell no! So i called around, Pep Boys charges $8 per rotor to turn rotors and $24 per wheel for labor, so i payed about $140 at Pep boys to turn my rotors compared to $320 at midas. Guess what? No more lights or messages ever since and it'* been 4 or 5 months. Seems that the Midas guy was the one not knowing what he was talking about.
BoneZ is offline   Reply With Quote
Old 03-06-2007, 10:52 PM   #16
Junior Member
 
Join Date: Aug 2005
Location: North of Buffalo, NY *** NEBF '05, '06, '07 *** ***ONBF & NYBF 06; 07*** ***WCBF 06***
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
singscountry1967 is on a distinguished road
Default

singscountry1967 is offline   Reply With Quote
Old 03-06-2007, 11:03 PM   #17
Senior Member
Posts like a Northstar
Thread Starter
 
Join Date: Dec 2002
Location: Bellbrook, Ohio
Posts: 547
Thanks: 0
Thanked 0 Times in 0 Posts
compyelc4 is on a distinguished road
Default

Thank you country singer.
compyelc4 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Service Stability System message - No Traction Control Sefrick 2000-2005 4 02-25-2008 03:02 PM
why is this happening to me? SES, Traction, ABS, Stability jwakamud 2000-2005 8 01-02-2008 12:25 AM
ABS/Traction light on...but i still have ABS ptrfair 2000-2005 0 12-11-2007 08:33 PM
Adding Traction Control/ Stability System marquette97 General GM Chat 2 08-09-2006 10:38 AM
'01 SSEi Intermediate Shaft = Stability Control System? compyelc4 2000-2005 3 08-27-2005 12:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:47 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.