Speedometer Jumping Around - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-08-2009, 12:07 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2007
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Hesk000 is on a distinguished road
Default Speedometer Jumping Around

In the past I've come to this forum with questions and I've gotten help 100% of the time, so I figured I come back again. Today I was driving to work and I noticed my Speedometer was jumping around when I let off of the gas. I was going about 40 mph and when I would let off of the gas it would move around, between 35 and 45 I'd say (It would never jump more than 5-10mph of how fast I was actually going). It would jump very eratically and it seemed as when I hit the gas it would go back to normal for the most part. I've also recently been noticing some hard shifting when it shifts into 2nd gear (very similar to the Pressure Control Solenoid problem located in the 2000-2005 common issues thread). The hardshifting issue doesn't happen all of the time, but I'm def noticing it. I wasn't so worried about the hardshifting just yet becasue its not that bad, but the Speedometer issue has forced me to schedule a stop at my local Auto Shop this Friday. I didn't know if these two issues might be somehow related? Any help would be greatly appreciated. Thanks

PS- car has 71,000 miles
Hesk000 is offline   Reply With Quote
Old 04-08-2009, 12:52 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I would say start with checking your plugs and connections going to the transmission and dash. Sound slike a poor connection to me.
Danthurs is offline   Reply With Quote
Old 04-10-2009, 03:48 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2007
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Hesk000 is on a distinguished road
Default

Thanks for the info. I checked out all of the connections and everything looks good. I took it to my local shop, who knows me, and they said they couldn't find anything. He was convinced its either the Speed Sensor or something within the dash. i wasn't going to pay 190 to have a speed sensor replaced when we weren't sure if that would fix it. Sure enough, on my way home, the speedometer starting jumping again. it seems to only do it once I've gotten over 40mpg or so. Anyone with a similar problem, i'd love to hear from you, thanks so much!
Hesk000 is offline   Reply With Quote
Old 04-13-2009, 04:17 PM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2007
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Hesk000 is on a distinguished road
Default

Well, after speaking with some other folks and driving the car more this weekend, I've noticed the problem getting worse. I first noticed the speedometer issue about a month ago and it only did it once and never did it again. Then a week ago it did it again and now its to the point where it does it everytime I drive the car. It seems after I've got the car good and warmed up and I've been driving for a little bit is when the Speedometer will start messing up again. The Speedometer has also started jumping around more eratically than before. As I said in the original post, I've also noticed some sluggishness and all around loss of performance in my car the last month or so. Someone was telling me that both these problems could be associated with the Mass Air Flow Sensor. Thoughts?
Hesk000 is offline   Reply With Quote
Old 04-13-2009, 04:54 PM   #5
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Unplug the MAF and drive without it. You will get a SES light. Just don't go over half throttle and you will be just fine. If the problem go away it could be the MAF, you can try cleaning it if that'* the case.
Danthurs is offline   Reply With Quote
Old 04-13-2009, 06:42 PM   #6
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Oct 2007
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Hesk000 is on a distinguished road
Default

Thanks, I appreciate it. My dad said he had the same problem (without the speedometer issue) and he cleaned his MAF and its been working fine since. I'm still a little up in the air as to if this is going to work or not but we're going to clean it. I already bought the cleaner so we'll soon find out. I'll let you know. Thanks again
Hesk000 is offline   Reply With Quote
Old 04-13-2009, 06:57 PM   #7
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Just make sure you don't touch the MAF wire, or spray directly on the wire. It'* very fine and can brake easy.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2001 Aztek speedometer jumping and going crazy- video posted usacamaro Pontiac 7 11-29-2011 02:21 PM
jumping speedometer rrrddgy 1992-1999 11 07-19-2005 11:49 AM
really jumping in here driverjohn2005 Lounge 12 12-30-2003 04:57 PM
Jumping pins for codes..quick question here!! 95neongirl 1992-1999 3 04-23-2003 12:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:48 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.