Speedo and Fuel guage not reading correctly - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-06-2010, 11:01 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
joehitech is on a distinguished road
Default Speedo and Fuel guage not reading correctly

I have a 2004 Bonneville SE. My wife tells me that they speedo is reading off. She was running maybe 50/55 and it read @ 130 and does not stay anywhere consistantly. She did try shutting the car off but it stayed at 10 mph with the key out. It also read wrong when restarted.

The fuel guage will also change readings at times. Most of the time it does read correctly but around 1/4 tank it moves toward the full side of the guage. Thoughts?? THANKS!!
joehitech is offline   Reply With Quote
Old 04-06-2010, 11:39 PM   #2
Senior Member
True Car Nut
 
Purplehazeir's Avatar
 
Join Date: Sep 2008
Location: Arlington, WA
Posts: 7,979
Thanks: 0
Thanked 1 Time in 1 Post
Purplehazeir is on a distinguished road
Default

When more than one gauge is reading goofy, that'* usually a sign that the gauge cluster is going out. Search the forum. There have been others with similiar problems that might have some solutions other than replacing the cluster. For instance, there'* a ribbon cable on the cluster that may have come loose, which would be an easy fix.
Purplehazeir is offline   Reply With Quote
Old 04-07-2010, 07:24 PM   #3
Junior Member
Thread Starter
 
Join Date: Oct 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
joehitech is on a distinguished road
Default

Thanks. I see that. I did also talk to a Pontiac mechanic and he told me to check the clusters ground wire at the top of the brake pedal bracket. That would too nice if it was the ground. Thanks again
joehitech is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel Gauge does not show correctly jrouter76 Pontiac 15 12-03-2010 03:45 PM
Outside air temp sensor not reading correctly Skippy1827 Your Other Rides: Pics & Videos 1 03-18-2008 10:39 AM
my dic is not working correctly? lol ...95 se 88bonnsse Everything Electrical & Electronic 8 07-19-2007 02:18 PM
Power locks not working correctly alec_b 1987-1991 9 02-05-2005 04:36 PM
Temperature Guage and Oil Guage stuck!!!!! Str8pimpin 1992-1999 4 10-13-2004 05:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.