recurrent O2 sensor codes - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-24-2003, 03:57 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: Feb 2003
Location: Bloomington-Normal, IL 1997 SE
Posts: 3,734
Thanks: 0
Thanked 0 Times in 0 Posts
macho_mike21 is on a distinguished road
Default recurrent O2 sensor codes

We have replaced the O2 sensors twice, the error codes come back after 24 hrs saying sensor heaters are malfunctioning. At last check today at Autozone, the codes were: PO135; PO140; PO141. Anyone had wiring harness problems in this regard?
macho_mike21 is offline   Reply With Quote
Old 12-24-2003, 10:06 PM   #2
Senior Member
True Car Nut
 
Join Date: May 2002
Location: Edmonton, AB Canada
Posts: 2,621
Thanks: 0
Thanked 0 Times in 0 Posts
DeathRat is on a distinguished road
Default Re: recurrent O2 sensor codes

Quote:
Originally Posted by macho_mike21
We have replaced the O2 sensors twice, the error codes come back after 24 hrs saying sensor heaters are malfunctioning. At last check today at Autozone, the codes were: PO135; PO140; PO141. Anyone had wiring harness problems in this regard?
Here'* a list of just about ALL the DTC'*.
http://www.bonnevilleattitude.com/fo...topic.php?t=62

DTC P0135 HO2S Heater Performance Bank 1 Sensor 1
DTC P0140 HO2S Circuit Insufficient Activity Bank 1 Sensor 2
DTC P0141 HO2S Heater Performance Bank 1 Sensor 2


Have you checked the wiring harnesses? The connectors? Maybe they got damaged during "install"? Check for "kinked" wires too. Are there any "Other" codes present that may shed some light here as to another problem present?
DeathRat is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Grrr, got crank sensor codes (whatsa 19?) J Wikoff 1992-1999 29 07-16-2006 05:07 PM
IAT sensor and trouble codes bonnevillemac 2000-2005 4 08-28-2005 11:29 PM
Bad O2 sensor but no codes??? Scrangler83 1987-1991 1 03-18-2005 01:08 PM
IAT sensor and trouble codes bonnevillemac Performance, Brainstorming & Tuning 3 03-11-2005 12:10 PM
recurrent O2 error codes macho_mike21 Everything Electrical & Electronic 0 12-22-2003 04:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.