IAT sensor and trouble codes - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 08-27-2005, 03:24 AM   #1
Senior Member
Posts like a Northstar
Thread Starter
 
bonnevillemac's Avatar
 
Join Date: Sep 2004
Location: The Bluegrass State
Posts: 522
Thanks: 0
Thanked 0 Times in 0 Posts
bonnevillemac is on a distinguished road
Default IAT sensor and trouble codes

Hey gang, it'* bonnevillemac (Tim for short), I have gotten an SES light on my car.
I used and OBD II scanner and the codes are coming up as follows

1). Intake air temp high input faulty

and

2). fuel too rich, Right Bank.

As my sig says I made a plexi box for my Air Filter, would taking off the side that is closest to the air intake on the fender help, or make no difference??

I have cleared the codes twice and they keep coming back.

Would the IAT sensor be bad?? If so can I get a replacement??

Any help is appreciated

Tim
bonnevillemac is offline   Reply With Quote
Old 08-27-2005, 11:56 AM   #2
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default Re: IAT sensor and trouble codes

Quote:
Originally Posted by bonnevillemac
Hey gang, it'* bonnevillemac (Tim for short), I have gotten an SES light on my car.
I used and OBD II scanner and the codes are coming up as follows

1). Intake air temp high input faulty

and

2). fuel too rich, Right Bank.

As my sig says I made a plexi box for my Air Filter, would taking off the side that is closest to the air intake on the fender help, or make no difference??

I have cleared the codes twice and they keep coming back.

Would the IAT sensor be bad?? If so can I get a replacement??

Any help is appreciated

Tim
Sounds like your IAT died, and that maybe causing your rich condiotion. But I'm not positive on that one.
LakevilleSSEi is offline   Reply With Quote
Old 08-28-2005, 08:47 AM   #3
Senior Member
Posts like a Northstar
Thread Starter
 
bonnevillemac's Avatar
 
Join Date: Sep 2004
Location: The Bluegrass State
Posts: 522
Thanks: 0
Thanked 0 Times in 0 Posts
bonnevillemac is on a distinguished road
Default

Hey Lakeville, thanks for the info. where would be the best place to check for an IAT??

I sorta thought about the IAT dying but wasn't sure.

Anywho, I can get a new been looking for a reason to spend some more money on the rgal8r anyway



Tim
bonnevillemac is offline   Reply With Quote
Old 08-28-2005, 11:12 AM   #4
Senior Member
True Car Nut
 
toastedoats's Avatar
 
Join Date: Sep 2004
Location: Fitchburg Ma _ToastedRice_
Posts: 6,837
Thanks: 0
Thanked 0 Times in 0 Posts
toastedoats is on a distinguished road
Default

just a wild guess, but did you break or pinch a wire on the IAT when you put in your new intake...? The IAT was the little guy with 2 wires going to it that was shoved into your intake ducting
toastedoats is offline   Reply With Quote
Old 08-28-2005, 11:29 PM   #5
Senior Member
Posts like a Northstar
Thread Starter
 
bonnevillemac's Avatar
 
Join Date: Sep 2004
Location: The Bluegrass State
Posts: 522
Thanks: 0
Thanked 0 Times in 0 Posts
bonnevillemac is on a distinguished road
Default

Don't reckon I broke or pinched a wire... I know what the IAT is and I used an extension harness to mount it. Of course that doesn't rule out the possibility of the wires.

I went ahead and bought a new one and went out to put it on but I can't find where the old sensor is. I saw the wires for it going into a black wire loom that went to a bunch of other wires. If someone could point me in the right direction I could definetly use the help. I gotta get it going 2morrow. I have to be at work. And I can't afford to miss.


Thanks for the help.


Tim
bonnevillemac is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
my trouble with Trouble Codes 1996 Bonneville SE 1992-1999 8 07-30-2007 11:08 PM
Trouble, trouble, trouble jbmark33 2000-2005 25 05-22-2007 10:11 PM
IAT Sensor on 2001? And Computer relocation? VanFaasenC Performance, Brainstorming & Tuning 2 09-21-2006 01:05 PM
IAT sensor integrated in Mass Air Flow Sensor? cballweg Bonneville GXP/ Northstar Powered Cars 6 05-04-2006 03:37 AM
IAT sensor and trouble codes bonnevillemac Performance, Brainstorming & Tuning 3 03-11-2005 12:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:29 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.