Front strut mount failure - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-01-2008, 08:35 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
bonnyguy is on a distinguished road
Default Front strut mount failure

Wondering if anyone here has suffered from premature front mount failures?

I had replaced my front mounts in early 2007 and by July 2007 the right mount had failed so I had the dealer replace both mounts and struts with OEM and the right just failed again today.

Any ideas?

Thanks!
bonnyguy is offline   Reply With Quote
Old 03-01-2008, 08:44 PM   #2
Senior Member
Posts like a Turbo
 
Join Date: Mar 2007
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
ptrfair is on a distinguished road
Default

http://www.bonnevilleclub.com/forum/...ht=solid+mount

I have had that problem and after reading, the next time my front mount gives, ill be doing the solid mount myself. I also have

The OEM mounts like driving with marshmellows. they engine moves alot. Thanks GM

hope this helps
ptrfair is offline   Reply With Quote
Old 03-01-2008, 08:50 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
bonnyguy is on a distinguished road
Default

Thanks for the information but the mounts I am referring to are the strut mounts not the engine mounts.
bonnyguy is offline   Reply With Quote
Old 03-01-2008, 10:26 PM   #4
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

What type of failure are you experiencing? What are the symptoms. There haven't been many reported failures.
Archon is offline   Reply With Quote
Old 03-01-2008, 10:57 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
bonnyguy is on a distinguished road
Default

Mount inner separates from the outer causing the strut shaft to push upwards and hit the underside of the hood.
bonnyguy is offline   Reply With Quote
Old 03-01-2008, 11:14 PM   #6
Senior Member
Posts like a Northstar
 
Join Date: Feb 2003
Location: Sacramento, CA WCBF '06, '07 survivor
Posts: 658
Thanks: 0
Thanked 0 Times in 0 Posts
rrounds is on a distinguished road
Default

bonnyguy,
If you can get some pic'* of that it would be great.
I have 165k on mine and they are still good, i have not heard about anyone else having this problem.
That could be real dangerous if that happened at speed. Please try to get some pic'* of this.

ROD
rrounds is offline   Reply With Quote
Old 03-02-2008, 12:08 AM   #7
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

I had that happen to one mount for the rear shocks, but have not had that issue with front struts...and is the first I recall hearing of it. So, this is the 3rd time?
Archon is offline   Reply With Quote
Old 03-02-2008, 10:31 AM   #8
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
bonnyguy is on a distinguished road
Default

Yup, third time and always on the passenger side.
If I drove on crappy roads then I would suspect that but 99% of my driving is paved highway. Only "bad" road I drive is my stone driveway!
bonnyguy is offline   Reply With Quote
Old 03-02-2008, 12:15 PM   #9
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

That is strange. Has the same place done the work each time? Is it done under warranty? Has the strut itself ever been replaced. I'm wondering if perhaps they aren't catching some other suspension problem that is leading to the mount failures. You may want to find a good frame and alignment shop, and have them do an inspection. If you can, get the old mount, and take it with you to the shop.
Archon is offline   Reply With Quote
Old 03-02-2008, 04:51 PM   #10
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
bonnyguy is on a distinguished road
Default

All work is done by my local dealer.
Strut was replaced at the same time as mount was in July 07.
This time will be replaced under warranty as all repair work from them carries a 12 month/12000 mile warranty.
bonnyguy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
W-Body rear strut tower failure! help ASAP! theedgeofsanity Pontiac 7 03-11-2010 01:20 AM
front strut mount Tone10 2000-2005 5 11-07-2009 01:19 PM
Front strut mount/bearings BonnevillesSince62 2000-2005 9 10-23-2008 11:31 AM
How to replace rear strut mount Masterbm 1992-1999 7 07-26-2005 12:10 PM
Strut bearing mount Mark Fahey 2000-2005 3 02-27-2005 01:38 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:07 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.