ELC not working? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


2000-2005 Discuss your 2000-2005 Bonneville SE, SLE, and SSEi Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 10-31-2007, 10:25 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2007
Location: minnesota
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
gearjammer is on a distinguished road
Default ELC not working?

Hi, I have a question about the elc system on my 01 bonneville. I know it should cycle every time the ignition is turned on but on mine very seldom do you ever hear it. I pulled both air lines off the shocks but didnt hear any air come out. the car sits nice and level unless there is a load in the trunk, then it will sag but there is still no sound of the compressor cycling. My question is, would the car still sit level if the system is not working? Should air come out if I disconnect the air lines or is there a one way valve in the shock or something. Any info would be appreciated, I cant stand it if i think something is wrong with my car if ya know what I mean. thanks.
gearjammer is offline   Reply With Quote
Old 10-31-2007, 10:30 PM   #2
Senior Member
Posts like a Northstar
 
Join Date: Sep 2006
Location: Long Island, NY
Posts: 601
Thanks: 0
Thanked 0 Times in 0 Posts
ChilinMichael is on a distinguished road
Default

The point of a load leveling system is to level the car when weight is added...if your car is on and you sit in the trunk say and it does not raise and there'* no sound of the compressor coming on...chances are something is wrong. Wait for gearheads to give you ways to diagnose...
ChilinMichael is offline   Reply With Quote
Old 10-31-2007, 11:17 PM   #3
Senior Member
True Car Nut
 
Join Date: Jan 2005
Location: Montevideo, MN MWBF '05, '06, '07 WCBF '06 '07 survivor
Posts: 3,882
Thanks: 0
Thanked 0 Times in 0 Posts
sonoma_zr2 is on a distinguished road
Default

with no air assist, your car will sit level by itself. if the air system is working, if you pull a air line from the strut, you will hear air escape, the system pressurizes on keyon. you said you don't hear the system on keyon, could be no power or the level switch is bad. the level switch is the brains of the elc system.
sonoma_zr2 is offline   Reply With Quote
Old 10-31-2007, 11:38 PM   #4
Junior Member
Thread Starter
 
Join Date: Oct 2007
Location: minnesota
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
gearjammer is on a distinguished road
Default

thanks for the replies, I bought the car about 3 months ago and noticed it would cycle(the compressor) about 3 or 4 key ons in a row and then I wouldnt hear it for probably 15 to 20 key ons, and continue on that pattern up until recently now where I havnt heard it in several weeks. Is that leveling switch difficult to replace if that is the problem?
gearjammer is offline   Reply With Quote
Old 10-31-2007, 11:41 PM   #5
Senior Member
Certified Car Nut
 
Join Date: Oct 2002
Posts: 11,307
Thanks: 0
Thanked 0 Times in 0 Posts
bonnie94ssei is on a distinguished road
Default

Not sure how it is on these, but my ELC didn't work on my 94, and it turned out to be the fuse...
bonnie94ssei is offline   Reply With Quote
Old 10-31-2007, 11:44 PM   #6
Senior Member
Posts like a Northstar
 
Join Date: Sep 2006
Location: Long Island, NY
Posts: 601
Thanks: 0
Thanked 0 Times in 0 Posts
ChilinMichael is on a distinguished road
Default

If you plan on keeping this car for a while, which we'd all hope I am sure, getting the shop manuals for it would not hurt (in my opinion) and in there would be the diagnostics on how to troubleshoot your issue...

You can usually eBay for the manuals or find them somewhere else on the net... I got a set for my 95 and they've been the best money spent yet for me...
ChilinMichael is offline   Reply With Quote
Old 11-01-2007, 12:17 AM   #7
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

In the meantime, this link should be able to help you out.
Suspension Control ( Automatic - Electronic Level )
Archon is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Elc dosent seem to be working anthonyc 1992-1999 3 12-08-2007 02:28 AM
97 sabre ELC still working? rogers Buick 2 08-24-2007 05:48 PM
Guages Not working and its Not a corrosion problem...... Dutch2005 Everything Electrical & Electronic 30 08-15-2006 01:24 AM
Twilight Sentinel working then not working on '95 SSEi mrstangblb 1992-1999 1 12-03-2004 09:30 PM
not good. NOT GOOD. (hit and run, not bad-BAD, but not good) repinS General GM Chat 13 11-26-2004 11:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.