What is wrong with my car! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-21-2005, 11:58 PM   #1
Senior Member
Posts like a Camaro
Thread Starter
 
looong4's Avatar
 
Join Date: Dec 2002
Location: Holly, Michigan
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
looong4 is on a distinguished road
Default What is wrong with my car!

Okay, i have been working on this pulling problem for a while. My car started off tugging to the the right slightly and got worse. It is worse at slower speeds.

Took to Belle tire they claimed it was brakes (caliper sticking), fixed those, replaced sway bar links, new struts about a month ago, alignment done and I have no idea what is wrong.

A bunch of retards work at Belle tire because they cant seem to figure it out. Its been there 5 times! They tried to tell me it was my rims/tires but the stock ones do it as well.

As if now it is still tugging to the right, and now its making a clunking/grinding noise when i turn and just a clunking noise when going slow. What else could go wrong up there???
looong4 is offline   Reply With Quote
Old 02-22-2005, 12:03 AM   #2
Senior Member
Certified Car Nut
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

Tie rod?
J Wikoff is offline   Reply With Quote
Old 02-22-2005, 12:10 AM   #3
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

Ball Joint? It basically means you have no alignment. Can mess everything up.
BonneMeMN is offline   Reply With Quote
Old 02-22-2005, 12:15 AM   #4
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

maybe its just the driver. :P

j/k

maybe a cv joint?
rjolly87 is offline   Reply With Quote
Old 02-22-2005, 12:19 AM   #5
Senior Member
Posts like a Camaro
Thread Starter
 
looong4's Avatar
 
Join Date: Dec 2002
Location: Holly, Michigan
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
looong4 is on a distinguished road
Default

Pretty sure not ball joint or tie rod. CV joint what are the symtems and exactly what is it?? How much and how hard..?? lol ive had somone else tell me a cv joint.
looong4 is offline   Reply With Quote
Old 02-22-2005, 12:26 AM   #6
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Quote:
Originally Posted by looong4
Pretty sure not ball joint or tie rod. CV joint what are the symtems and exactly what is it?? How much and how hard..?? lol ive had somone else tell me a cv joint.
i know they put up quite a fuss in the turns under power when they are bad, i dont know about straight line though. if your problem it the cv joint, it is beyond bad. somebody back me up, i never let mine go beyond the chattering.
rjolly87 is offline   Reply With Quote
Old 02-22-2005, 12:31 AM   #7
Senior Member
Posts like a Camaro
Thread Starter
 
looong4's Avatar
 
Join Date: Dec 2002
Location: Holly, Michigan
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
looong4 is on a distinguished road
Default

The noise just started. But it seem like Belle tire woulda noticed it.
looong4 is offline   Reply With Quote
Old 02-22-2005, 12:39 AM   #8
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

There will be a black rubber boot on your axle at a joint. Check it to see if it'* still there and in one piece. If it'* torn or missing, you may need to replace the joint, minimum lube it up.
BonneMeMN is offline   Reply With Quote
Old 02-22-2005, 12:50 AM   #9
Senior Member
Posts like a Camaro
Thread Starter
 
looong4's Avatar
 
Join Date: Dec 2002
Location: Holly, Michigan
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
looong4 is on a distinguished road
Default

K, the boot is in one peice, looks like there is some lube leaking out... that normal? I just replaced struts/ strut mounts ext. Possible i coulda put somthing in wrong? This started after the alignment after the struts were done.
looong4 is offline   Reply With Quote
Old 02-22-2005, 02:15 AM   #10
Senior Member
Posts like a Camaro
Thread Starter
 
looong4's Avatar
 
Join Date: Dec 2002
Location: Holly, Michigan
Posts: 1,181
Thanks: 0
Thanked 0 Times in 0 Posts
looong4 is on a distinguished road
Default

It was grey i am pretty sure.. would this cause my car to pull and make these noises tho? It was coming out beween the boot and the axel, not out of a tear. I will look closer tomorrow. thanks
looong4 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wrong place at the wrong time.. UPDATE bonnie94ssei Forced Induction 19 09-17-2006 06:39 PM
Wrong Just Wrong BLACK94SSEi Lounge 24 03-30-2006 11:44 PM
help my car got painted the wrong color 92olds88royale Detailing & Appearance 20 03-14-2006 11:14 AM
whats wrong with this car 1993 SLE General GM Chat 20 04-21-2005 01:01 PM
Figured out what was wrong with the car jachin 1992-1999 2 02-17-2004 08:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.