UGH!! I Think I killed my Bonnie... - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-25-2006, 12:54 PM   #11
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Aug 2005
Location: Cape May New Jersey at the Shore
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
butkus21 is on a distinguished road
Default

Thanks for the sympathy...
Yeah he did say it was a bearing..
I'm not putting anymore $$$ into this car.. close to 7 grand into a 95 se in almost 3 yrs in enough.. I don't love the car that much.. Its not my 89 350 GTA that I bought new..
Thanx for the advice.. wish me luck..
butkus21 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
i think i killed my bonnie ricosuave420 General GM Chat 44 04-29-2009 05:54 PM
Ugh CV boot SSEimatt93 General GM Chat 4 06-06-2003 01:56 AM
Ugh.. I feel sick. smellbird Lounge 2 03-18-2003 08:58 PM
Stock SSEi Killed and has been Killed BigAl General GM Chat 3 08-01-2002 11:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:41 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.