Sunroof Not Working!!! - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 12-03-2010, 08:36 PM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
DirtyRob is on a distinguished road
Default Sunroof Not Working!!!

Today I was driving and my sunroof opened by itself and won't close at all. It seems to have no power at all. I checked the circuit and had it tested and it was fine. I'm thinking maybe a relay but whice relay is it. I check the ones on the passenger side and none of them say anything about sunroof. I pulled the power windows accessory and the windows quit working so it'* not that relay. The windows work fine just not the sunroof. I don't get it how it just opened by itself on it'* on and quit working. Also to mention my headliner does leak and it does get wet around the switch area so maybe it can be water damage to wires or the motor (hopefully not). Any kind of info would be appreciated.

Also where is the sunroof relay located?
DirtyRob is offline   Reply With Quote
Old 12-03-2010, 11:00 PM   #2
Junior Member
Thread Starter
 
Join Date: Nov 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
DirtyRob is on a distinguished road
Default

I did some reading and found some other options. I might try to take the headliner down tomorrow and test the motor or try to manually close it. I would rather just get it closed for now. It'* supposed to snow for the next few days so I got to get it closed up. I put some plastic over it tonight to keep it closed.

Does anyone know how to close a sunroof manually on a 94 ssei?
DirtyRob is offline   Reply With Quote
Old 12-06-2010, 07:02 AM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2010
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
DirtyRob is on a distinguished road
Default

For now I just got some plexi glass and some heavy duty plastic and ducted taped the hell out of it. It'* too cold to be outside messing with a sunroof. As long as the cold and snow stays out it will be fine. I even fixed the leak I had in the sunroof so now no leaks. I'll worry about it in the spring. From what I inspected so far it seems like the module went out. It seems to have power because you can hear a clicking noise from the motor area. I'll have to tear down the headliner and do some more investigating to be sure.
DirtyRob is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Guages Not working and its Not a corrosion problem...... Dutch2005 Everything Electrical & Electronic 30 08-15-2006 01:24 AM
Instrument Display/Backlights Not Working (Not a Fuse) DavidR Everything Electrical & Electronic 3 10-26-2005 03:51 PM
sunroof not sitting flat Custom88 2000-2005 11 04-25-2005 08:53 AM
Twilight Sentinel working then not working on '95 SSEi mrstangblb 1992-1999 1 12-03-2004 09:30 PM
not good. NOT GOOD. (hit and run, not bad-BAD, but not good) repinS General GM Chat 13 11-26-2004 11:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:21 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.