Speedometer going whacky - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 09-27-2005, 05:40 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jun 2003
Location: Harrisburg, PA
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Pimpwagon is on a distinguished road
Default Speedometer going whacky

My speedometer will bounce around while driving. Example: I will be driving 70MPH and it will fall to 80 or 90 then jump back to 70. The duration varies and it can also read slow. I notice it will jump when I use my turn signal as well but not all the time. I checked my altenator and it is putting out 13.7 volts. What is the cause?

96' bonneville SE 214K miles 3.8 no supercharger.
Pimpwagon is offline   Reply With Quote
Old 09-27-2005, 05:45 PM   #2
Senior Member
Certified Car Nut
 
Join Date: Mar 2003
Posts: 12,432
Thanks: 0
Thanked 0 Times in 0 Posts
J Wikoff is on a distinguished road
Default

Do any other gauges act funny?
J Wikoff is offline   Reply With Quote
Old 09-27-2005, 05:49 PM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jun 2003
Location: Harrisburg, PA
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Pimpwagon is on a distinguished road
Default

Nope, everything else is fine.
Pimpwagon is offline   Reply With Quote
Old 09-27-2005, 05:57 PM   #4
BANNED
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
banned3800 is on a distinguished road
Default

You may want to get a scantool on it and see if the PCM is seeing the same thing... Either the speedo on the cluster could be bad/ or possible bad connection, or the Vehicle Speed Sensor may be getting funky... Good Luck

__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
banned3800 is offline   Reply With Quote
Old 09-27-2005, 09:13 PM   #5
Junior Member
 
Join Date: Mar 2003
Location: Purgatory
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
vital49 is on a distinguished road
Default

Quote:
Originally Posted by jr's3800
You may want to get a scantool on it and see if the PCM is seeing the same thing... Either the speedo on the cluster could be bad/ or possible bad connection, or the Vehicle Speed Sensor may be getting funky... Good Luck
I'd have to bet it'* the VSS. I had the same thing happen to me on a 92 Gutless Ciera. Had the 3300. I had the VSS changed and the problem never returned.
vital49 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2001 Aztek speedometer jumping and going crazy- video posted usacamaro Pontiac 7 11-29-2011 02:21 PM
Phantom Check Engine Light/Rough Engine/Coolant Temp. Gauge Whacky RWW2003 1992-1999 10 11-13-2009 08:00 AM
whacky guages fly,nlow 2000-2005 5 01-22-2009 04:37 PM
'57 Bonneville...going, going, gone!! mac077 General GM Chat 5 06-27-2007 12:52 PM
Harmonic damper going, going ... five7kid 1987-1991 8 06-30-2006 11:12 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.