So annoying - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 04-17-2009, 06:35 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: Illinois
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Momof2boys is on a distinguished road
Default So annoying

Please excuse my ignorance. I know nothing about cars other than to be able to explain what is going on as I drive. Also what the guy who has worked on it is telling me. So if I sound completely stupid I am sorry. Just looking for some help understanding what the heck is going on.


So my car has been running real bad. Last week the engine light started blinking and the car started to run real rough. like it was not running on all the cylinders. kind of like it was hesitating to go. It started to get really bad in between 2000 and 3000 rpm'*. While this was happening the battery meter would drop to about 8 or 9.
Took it to my friends husband, he did a computer test and said there was a misfire code.He replaced all 3 coil packs all the plugs and wires. Gave it back and said it should be good. The engine light was off for a day and now it is back on. I can feel the misfire still when I reach 20 mph.Kind of like it wants to die until I get going faster.
Not as bad but it is still there. The battery is not moving but I have a feeling that is only a matter of time. I had previously had to put the car in neutral and press the gas while it is at a idle.
I told him about this and he said I may need a new module. I am so confused.
I am so scared to drive my car after what has already happened and being as I have 2 boys in baseball and a job I need to drive..kwim

Thanks in advance for all help
Momof2boys is offline   Reply With Quote
Old 04-17-2009, 06:38 PM   #2
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Hey there Mom,

We want to help!

So first we need to know what year make and model is your Bonneville.

-Todd
Toddster is offline   Reply With Quote
Old 04-17-2009, 06:43 PM   #3
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: Illinois
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Momof2boys is on a distinguished road
Default

Hi !
It is a 97 SE
it says 3.8 on the motor cover and I am almost positive it is a 6 cylinder
Momof2boys is offline   Reply With Quote
Old 04-17-2009, 06:46 PM   #4
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Oh ok. Thanks for that.

Do you know what brand of spark plugs he put in?

Have you checked your battery cables for bad corrosion or if they are loose?
Toddster is offline   Reply With Quote
Old 04-17-2009, 06:55 PM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: Illinois
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Momof2boys is on a distinguished road
Default

I believe he used Duralast plugs. I know I paid like 8.00 a piece for them. I have checked the cables and there is nothing on them and they are not loose. I did just replace the battery in January.
Also last year I had a new alternator put in.
He is saying the engine light on steady is o.k, it is "probably just a emission issue"
Momof2boys is offline   Reply With Quote
Old 04-17-2009, 07:00 PM   #6
Junior Member
 
Toddster's Avatar
 
Join Date: Aug 2005
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Toddster is on a distinguished road
Default

Do you know when the last time the fuel filter was replaced?

I've never heard of Duralast plugs....

Also do you have a Auto Parts Store near by you? If you do bring it there so they can scan it for you. It'* almost always free to scan the engine light.

I'll be back little later. I'm sure others will chime in soon.

-Todd
Toddster is offline   Reply With Quote
Old 04-17-2009, 07:05 PM   #7
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: Illinois
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Momof2boys is on a distinguished road
Default

Thanks Todd
No idea about the fuel filter, bought the car used and I don't remember having it replaced.
I am sorry about that I think he said Ac delco plugs or something like that. Sorry my brain in overloaded right now. I have no idea where I came up with duralast lol
I do have a AP store by me I will drive it over tomorrow and get that test done.
Momof2boys is offline   Reply With Quote
Old 04-17-2009, 07:22 PM   #8
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

I'm thinking a vacuum leak here. So test that by spraying carb cleaner on the vacuum lines while the car is running. A change in RPM will tell you you have a leak. Check your rear spark plug wires to make sure they are not touching the rear O2 sensor wire.

Another possibility is the Throttle possistion sensor. There'* a test for that in the tech info area. You could have your friend check that.
Danthurs is offline   Reply With Quote
Old 04-20-2009, 09:58 AM   #9
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: Illinois
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Momof2boys is on a distinguished road
Default

UPDATE:

So I took my car to the auto part store and got the computer read. It was reading a cylinder 3 misfire along with a code for the gas cap not being tight enough.
I bought a new plug and wire for cylinder 3, followed the number on the new coil packs and changed the plug and wire all by myself
The old wire just broke apart when I pulled it off, like it had been melted or something.

My engine light went off when I started it back up and it is running like a champ.

Pisses me off that I just spent 150.00 on new coil packs along with labor for my friends husband to change them, but whatever at least I know I have another brand new part on my car.
My next paycheck I plan on getting the other 5 wires and plugs and swapping them out, just to make sure they are all good.

The auto part guy told me the gas cap is not really that big of a deal and if my engine light comes back on to go in and buy a new gas cap.

Friends husband is telling me to make sure to change my ignition module. Is that a must right now? Not to sure whether or not to trust him when I spent 150.00 for something that was a 14.00 fix.

Thanks everyone for your help. this place rocks!
Momof2boys is offline   Reply With Quote
Old 04-20-2009, 10:50 AM   #10
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

The ignition module should not be the issue. Like the cols..it'* frequently misdiagnosed. If the ICM (Ignition Control Module) was the issue, you should see other issues on more cylinders since each coil provides the spark to two cylinders.

He should have noticed the bad wire when he was looking it over before shotgunning parts on it that the car didn't need.
BillBoost37 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Very Annoying Drivers Info Center shortstuf212559 1987-1991 11 10-07-2003 09:07 PM
Whats the most annoying thing people do in or to your car? h1081dan Lounge 32 10-01-2003 09:36 PM
93 SSE annoying popping from the rear csomb42 1992-1999 4 06-21-2003 11:05 PM
Annoying Sunroof willwren 1992-1999 9 04-19-2003 11:17 AM
Annoying vibrating noise! What is it???!! bonnie94ssei 1992-1999 12 02-10-2003 02:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:18 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.