rear 4t60 mount (not dogbone) - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-16-2006, 10:11 AM   #11
Senior Member
True Car Nut
Thread Starter
 
95naSTA's Avatar
 
Join Date: Feb 2003
Location: Philly
Posts: 4,508
Thanks: 0
Thanked 0 Times in 0 Posts
95naSTA is on a distinguished road
Default

Yep it was pretty easy. I even had the ends of the axles still in the trans.
95naSTA is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Dogbone mount replacement 1995 Vin K ChilinMichael 1992-1999 12 02-05-2007 11:02 PM
Rear Dogbone Part # and picture? 95naSTA 1992-1999 9 10-12-2005 12:40 PM
Final drive for 3.33 4t60, 3.06 4t60, 2.9x 4t65-HD 95naSTA 1992-1999 7 09-27-2005 02:17 AM
Simple question on Dogbone engine mounts bonnie94ssei General GM Chat 17 08-21-2004 08:55 PM
Trans physical mounting locations 4T60 vs 4T60-E JaxxMan 1987-1991 14 10-27-2003 09:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.