quad driver module 4 fault - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-02-2009, 10:51 AM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Dec 2007
Location: atlanta,ga
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
vdawg4 is on a distinguished road
Default quad driver module 4 fault

hey guys, my 95 bonni ssei supercharged, is running like crap. surgeing at idle, stumbling and hesitating on acceleration. i checked and replaced worn vaccum lines. it did no good. i hooked up the scanner and got two codes po118 coolent temp sensor and p0670 quad driver module 4. before i go out and replace the computer, i would like to make sure its not a short in a solinoid or something else. from my research i have dedermined quad 4 controls the ac clutch and 2 cooling fans.?? i need to confirm what the quad 4 controls, how to check if i have a failure, and if this would be causing my driveability problems. thanks very much for any help. vernon Also, the ac and cooling fans appear to be working fine...

Last edited by vdawg4; 07-02-2009 at 10:53 AM.
vdawg4 is offline   Reply With Quote
Old 07-02-2009, 12:16 PM   #2
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Fix the coolant sensor. That will likely fix the running like crap issue.

The Quad 4, there'* two and it looks like you've done your homework on which items it controls for the one you have. Check the resistors on the fans, all the things you can on those items. While the pcm is the flakiest flake out there in 95, in my case...it didn't lie about a quad driver. But I did find it the hard way. Mine was the evap, BCS and TCC driver. Everything worked great...I swapped the bcs and it was like magic.
BillBoost37 is offline   Reply With Quote
Old 07-05-2009, 10:55 AM   #3
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Dec 2007
Location: atlanta,ga
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
vdawg4 is on a distinguished road
Default

thanks bill, i got he temp sensor in and have seen some improvement in driveability. i am still getting the surge at idle..i am not positive what the quad driver module 4 controls on my year model...and think i may have a problem with my bcs.. i ran the test where you plug the vacuum line and the surging went away... i can't find a bcs anywhere online or at parts store.. i have not tried the dealer.. just giving an update and thanks again for yor help. vernon
vdawg4 is offline   Reply With Quote
Old 07-05-2009, 10:21 PM   #4
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

The code you reference is the AC relay, MIL light, Low speed cooling fan, and high speed cooling fan.

The surging you mention sounds like a vacuum leak. Touch the vacuum hoses with a finger. If your finger has black vacuum stuff on it replace them. Don't forget the ones under the airbox by the charcoal canister.
BillBoost37 is offline   Reply With Quote
Old 07-06-2009, 12:28 PM   #5
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Dec 2007
Location: atlanta,ga
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
vdawg4 is on a distinguished road
Default

Really appriciate your help on this...here is whats happening.. i replaced the bottom( Larger) vac line to the cannister and the drivability problems have gone away...But the readings on my scanner are weird. (actron cp 9145) .I erased the previous codes, drove the car and while running parked, read new codes. it came up with one history code the coolent temp code. went to view details and and it had the coolent temp fluctuating from 204 to 304 degrees. also where it says current codes, it flashed fast "yes/no, yes /no" " then on O2 again flashing fast "rich/lean rich/ lean". meanwhile, the cel is lighted and the driver information center (diagram of car) flashes the engine and chimes, stops for a few seconds and then lights and chimes again at irregular intervals.. my question is, do the mil go bad and can they be fixed or does this look like i may be needing a new computer after all? thanks again for any help. vernon
vdawg4 is offline   Reply With Quote
Old 07-06-2009, 02:40 PM   #6
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

With the engine off and key on, does it show any current codes?

Could be the pcm, the down side of a pcm is there'* really no true way to say it'* definately the pcm. Do you know of anyone with a 94/95 H body in yoru area that you could swap pcm'* with to try a known good one?
BillBoost37 is offline   Reply With Quote
Old 07-07-2009, 10:41 AM   #7
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Dec 2007
Location: atlanta,ga
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
vdawg4 is on a distinguished road
Default

with the engine off and the key turned on i am now getting system pass no codes...yet the mil light is going haywire.. yesterday while i had it running.. the scanner said no codes but i was getting the mil light and the car information had the engine bay lighted..i don't know why the quad mod 4 fault error went away.. no i really do not have anyone i can swap out with... can you tell me where the ecm is located on the care and is it difficult to change out.. looking on the web, i saw an ecm for about 85.00thanks again for being so helpfull, vernon..
vdawg4 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Code 26 Quad driver module????? I need help!! sellncars 1992-1999 7 04-18-2005 09:30 PM
Code 26 - Quad Driver Module Circuit faisalmali 1992-1999 5 09-13-2004 12:52 PM
quad driver module info enmityst 1992-1999 5 03-23-2004 12:30 AM
Another quad driver module question riotact 1992-1999 7 07-20-2003 11:34 PM
1992 bonneville trouble code 26 quad driver module circuit riotact Performance, Brainstorming & Tuning 6 06-22-2003 08:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:46 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.