Oil pressure gauge acting wonky... :? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-30-2005, 07:12 PM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
Join Date: Sep 2004
Location: Ontario
Posts: 179
Thanks: 0
Thanked 0 Times in 0 Posts
Iceman is on a distinguished road
Default Oil pressure gauge acting wonky... :?

I noticed the other day when I was driving to Barrie...
the needle was pegged on high, and it would dance around
from 3/4 to full on, changing as I went from OD (3/4) to 3rd (full)

So what'* wrong here? Sending unit? gauges?

I'll get a vid of it if it'll help diagnosis

Thanks,
Matt
Iceman is offline   Reply With Quote
Old 06-30-2005, 07:33 PM   #2
Senior Member
True Car Nut
 
Join Date: Feb 2002
Posts: 3,993
Thanks: 0
Thanked 0 Times in 0 Posts
JimmyFloyd is on a distinguished road
Default

Mine was doing that, except it would start at 40psi, then then work it'* way up, spiking occasionally until it pegged for good. Turned out to be the oil pressure sending unit. I just unplugged the wire to it and then plugged it back in, and that solved most of my problems, but I have a new one to go in (thanks bill) when I get a chance. If you need to change it, I found it is easiest to get to if you remove the passenger wheel and the splash shield behing the wheel (not the plastic inner fender). Not sure how hard that is to remove since I didn't have one on my car after the engine swap. But with it removed, you can access it easy.

You can kinda see where I am talking about in this picture:
http://bizio.homeftp.org/geoff/BC/sseiday/DSC05244.JPG

I believe there is supposed to be a splash shield above where the jack stand is and the Oil Pressure Sensor is right behind the strut on the motor.
JimmyFloyd is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My oil pressure gauge is acting like a tachometer? LeSabreUltra 1992-1999 3 03-05-2010 06:54 PM
My oil pressure gauge is acting up. suctoes 1992-1999 3 11-10-2005 08:37 PM
Starter Removal Diffuculty and oil pressure gauge acting odd WickedJstr 1992-1999 5 09-26-2005 06:44 PM
Oil pressure guage acting funny jkust 1992-1999 14 09-08-2005 01:16 PM
Wonky Hood-Camber problem Jim W 1987-1991 13 05-16-2003 09:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:21 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.