New plugs and wires and... burning smell? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-08-2007, 06:09 PM   #1
Senior Member
Posts like a Turbo
Thread Starter
 
Join Date: Oct 2006
Posts: 441
Thanks: 0
Thanked 0 Times in 0 Posts
zuper8 is on a distinguished road
Default New plugs and wires and... burning smell?

I just put on autolite coppers and belden wires by myself for the first time. Started it, and it runs fine but makes a really foul smell, and it kind of smells like burning. I'm afraid to drive it. Oh yeah, and my fans came on instantly, and the car hasn't been driven in days, don't they only come on after like 220 degrees? I'm supposed to be travelling tonight and I'm scared to drive. I wasn't sure how which wires went where, I matched them up just by the exact length because they weren't marked. I was careful to arrange them as they were. Is it possible I did the wires wrong?
zuper8 is offline   Reply With Quote
Old 06-08-2007, 07:07 PM   #2
Senior Member
Certified GM nut
 
Join Date: May 2005
Location: Wickliffe, Ohio
Posts: 2,155
Thanks: 0
Thanked 0 Times in 0 Posts
McGrath is on a distinguished road
Default

Maybe the smell is your cat going on you... Or maybe you just got some dirt on your manifolds which is burning off. You'd know if you mixed up the wires the motor would run like crap, the best way to do wires is one at a time so you can't mix them up.

Ed
McGrath is offline   Reply With Quote
Old 06-08-2007, 07:12 PM   #3
Senior Member
True Car Nut
 
Join Date: Sep 2004
Location: Farmington, Minnesota =MWBF '05 SURVIVOR= =CEBF '06 SURVIVOR= =August '06 COTM=
Posts: 9,130
Thanks: 0
Thanked 0 Times in 0 Posts
LakevilleSSEi is on a distinguished road
Default

Make sure you don't have any of the wires resting on the exhaust manifolds.
LakevilleSSEi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Burning Wire Smell BiG-MaTT 1992-1999 9 01-03-2011 11:27 PM
Two issues: 1. High beam switch and 2. burning smell Skippy1827 1992-1999 2 02-07-2008 01:24 PM
Coolant Leaking (Burning?) Smell 92BonneSE 1992-1999 2 02-03-2006 10:56 PM
Plastic Burning Smell, Bonnie vibrates after 50mph - HELP 2000SLE 2000-2005 11 11-16-2005 06:40 PM
Burning smell.... still here after many months big_news_1 1992-1999 17 03-04-2005 10:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.