Mechanical concerns on my new (used) Bonne... - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-24-2003, 05:16 PM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2003
Location: Minneapolis, Minnesota
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
TDS-94SSEi is on a distinguished road
Default Mechanical concerns on my new (used) Bonne...

Hey all,

Recently found this forum. My wife and I just picked up the '94 SSEi in my sig.
Got a decent deal, but there are a few things that I would like to straighten out to improve the car. As follows:

1. "Ride Quality" selector, near the shifter. Pushing the buttons does nothing of notice. Both are lit like they are selected. Should this be a "one-or-the-other" type thing, or is mine OK? I'm guessing that the driver doesn't really notice much change from mode to mode. Am I right?

2. no light in my "Traction Control" selector in the same area. Granted that there is the indicator in the digital dash that tells me when that is turned off, but wondering if the pushbutton should light up as well?

3. console lid release button is busted. Seems to have been wiped out when the car got it'* "thorough" cleaning from the selling dealer. Seems like a simple enough thing to repair, I figured I'd tackle it rather than mess with the dealer and try and convice them that they were responsible, since I have no proof that it wasn't that way on out inital test drive. Source for latch ***'y. maybe??

4. the hand hold over the passenger window is missing. I'm hoping that I can score one of these from pretty much any Bonne I might come across in the junkyard. Any reason that this car would have any special interior trim package or something that will make this piece hard to find? The rears have a lamp built in, but the front looks to lack any elec. connection, I'm hoping it'* much simpler...

5. power antenna is a little flaky. like pretty much every other GM power antenna that I have ever had, actually. Looks easily swappable, just curious if I have bad luck, or are these prone to having problems. Seems to stick before the last segment is retracted. A little pressure on it, and it does go all the way down on it'* own though.

6. What'* the story on these power seats? reliable? All my buttons seem to do something, but dang, ther sure are a lot of them!!!!

All of these are fairly minor things, but there'* one more that I plan on having someone perhaps a bit more skilled in these cars check out.

I occasionally get the "brake" light on the dash lighting up. Seems to mostly happen in "stop-and-go" situations. The light will come on briefly after letting go of brake pedal and pressing the accelerator. brakes seem to work great though. Visual inspection didn't really show me anything that LOOKED wrong, at least to me. This is my first car with ABS, so I'm a little intimidated by that. Any way to troubleshoot this on my own? And, this car has the OBDII computer system, right? Is that more complex than the earlier system, if it does. I am used to diagnosing a lot using my trusty Paperclip. Can I continue, or do I need a good scanner now??

Thanks for bearing with the long post, but I thought I'd get 'em all out in one here. Please share any thoughts/stories you might have. Thanks!!
TDS-94SSEi is offline   Reply With Quote
Old 06-24-2003, 05:40 PM   #2
Senior Member
Posts like a Supercharger
 
Join Date: May 2003
Location: Calgary, Canada
Posts: 175
Thanks: 0
Thanked 0 Times in 0 Posts
bonnycrazy is on a distinguished road
Default

welcome to the club ok lets see what we can do.......

''''1. "Ride Quality" selector, near the shifter. Pushing the buttons does nothing of notice. Both are lit like they are selected. Should this be a "one-or-the-other" type thing, or is mine OK?''''

i think if they're both lit ''lights'' , there is something wrong. i have a 94 ssei and u can only choose one of course ur talking about ''perform ride'' and ''normal ride'' right? i'm sure someone else here can help u with that but it doesn't sound normal......


''''2. no light in my "Traction Control" selector in the same area. Granted that there is the indicator in the digital dash that tells me when that is turned off, but wondering if the pushbutton should light up as well? ''''


Most likley a burnt out bulb.



''''3. console lid release button is busted. Seems to have been wiped out when the car got it'* "thorough" cleaning from the selling dealer. Seems like a simple enough thing to repair, I figured I'd tackle it rather than mess with the dealer and try and convice them that they were responsible, since I have no proof that it wasn't that way on out inital test drive. Source for latch ***'y. maybe?? ''''


I think there is a easy fixer upper for this one in ''TECHNIFO'' if i'm not mistaken, but just to let u know , 9 out of 10 break!!!!!!!! mine was broken when i bought it , but the previous owner used velcro. i didn't like it so i scored one from a junkyard! it'* not just the latch, it'* the whole inner piece u need.


'''5. power antenna is a little flaky. like pretty much every other GM power antenna that I have ever had, actually. Looks easily swappable, just curious if I have bad luck, or are these prone to having problems. Seems to stick before the last segment is retracted. A little pressure on it, and it does go all the way down on it'* own though. '''



sprayed mine with WD-40 , seems to be working fine now



'''6. What'* the story on these power seats? reliable? All my buttons seem to do something, but dang, ther sure are a lot of them!!!! '''''


VERY comfy , but all my lumbar buttons do not work

I occasionally get the "brake" light on the dash lighting up. Seems to mostly happen in "stop-and-go" situations. The light will come on briefly after letting go of brake pedal and pressing the accelerator. brakes seem to work great though. Visual inspection didn't really show me anything that LOOKED wrong, at least to me. This is my first car with ABS, so I'm a little intimidated by that.''''


sounds to me you're low on brake fluid . if there was a problem with ur ABS , the ''ABS'' light would have came on
as for scanning , u need a computer i think.

good luck bud

Al
bonnycrazy is offline   Reply With Quote
Old 06-25-2003, 02:02 AM   #3
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

You have the strange hybrid computer system. It is an OBD-1 pretending like it is an OBD-2. You need an OBD-1 scanner with a 12 to 16 pin adapter to retrieve codes.

Your electronic adjusting struts have a problem. When both lights are lit that means one or more of the struts is not adjusting. I believe these will give codes to help diagnose them. I don't have the service manual for that, though! Maybe someone else can help.

I would bet the LED is burned out in your traction control switch.

I think your other problems have been discussed already.
fuddyduddy121 is offline   Reply With Quote
Old 06-25-2003, 03:10 AM   #4
Junior Member
 
Join Date: Aug 2002
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Custom88 is on a distinguished road
Default

our 1995 SSE had the same problem with both of the lights lit up. That car needed new struts on it though, so I assume that'* what the problem was on it. It had always been like that though for as long as we had it..
Custom88 is offline   Reply With Quote
Old 06-25-2003, 03:40 PM   #5
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2003
Location: Minneapolis, Minnesota
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
TDS-94SSEi is on a distinguished road
Default

Thanks for the replies eveyone!!

That gives me some ideas on where to start at least. Loving the car so far, except that it is so much bigger than the others I have, that I had to totally rearrange my garage to fit it in there! Now to get after some of these little issues one of these days.
TDS-94SSEi is offline   Reply With Quote
Old 06-25-2003, 11:30 PM   #6
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Quote:
Originally Posted by TDS-94SSEi
Thanks for the replies eveyone!!

That gives me some ideas on where to start at least. Loving the car so far, except that it is so much bigger than the others I have, that I had to totally rearrange my garage to fit it in there! Now to get after some of these little issues one of these days.
RE: The console lid: Might as well try to order that from the dealer while you still can. I assume you need the inner lid liner, which includes the large tooth on the front that engages the latch, at least until you break it off with your elbow. Mine usually stays shut anyway, so I've stashed the replacement away until the day I sell the car (in 2037 )

You don't mention anything about a flip-out cupholder inside the center console, hinged on the front of the console opening; did you find one?
acg_ssei is offline   Reply With Quote
Old 06-26-2003, 10:52 AM   #7
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2003
Location: Minneapolis, Minnesota
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
TDS-94SSEi is on a distinguished road
Default

Quote:
Originally Posted by acg_ssei

RE: The console lid: Might as well try to order that from the dealer while you still can. I assume you need the inner lid liner, which includes the large tooth on the front that engages the latch, at least until you break it off with your elbow. Mine usually stays shut anyway, so I've stashed the replacement away until the day I sell the car (in 2037 )

You don't mention anything about a flip-out cupholder inside the center console, hinged on the front of the console opening; did you find one?
Oh no, this lid is gonna be just like the one in our *-10 Blazer, that my wife keeps on breaking?!?!?!?! :(
Well, it looks to me that the "tooth" part is there and in tact. But there'* nothing in the receiving part of the console to grab into it. And my button is flopped down into the depressed position. I noticed this when the rear part of the shifter/seat control inlay was pushed down into the console, like someone leaned too heavily on it. I think I will need to take it all apart so I can figure out for sure what part I am going to need. Our lid is spring loaded, so it wants to sit open now. Looks trashy.
We do have that flip-out cupholder in there, at least. First vehicle I've ever had that has a cup holder. (I know, the rest are all old relics...) Of course I haven't used it, yet.
TDS-94SSEi is offline   Reply With Quote
Old 06-26-2003, 11:33 AM   #8
Senior Member
True Car Nut
 
Join Date: Sep 2002
Location: Chicago, IL
Posts: 2,409
Thanks: 0
Thanked 1 Time in 1 Post
acg_ssei is on a distinguished road
Default

Quote:
Originally Posted by TDS-94SSEi
Well, it looks to me that the "tooth" part is there and in tact. But there'* nothing in the receiving part of the console to grab into it.
Amazing; on most cars it'* the other way around.

Quote:
Originally Posted by TDS-94SSEi
And my button is flopped down into the depressed position. I noticed this when the rear part of the shifter/seat control inlay was pushed down into the console, like someone leaned too heavily on it.
Yes, as far as I can see, the filler part that'* pushed down on your car is basically unsupported to begin with.

Quote:
Originally Posted by TDS-94SSEi
I think I will need to take it all apart so I can figure out for sure what part I am going to need.
Ayup. I think somebody wrote instructions for that in the TechInfo section.

Quote:
Originally Posted by TDS-94SSEi
We do have that flip-out cupholder in there, at least. First vehicle I've ever had that has a cup holder.
Ohmigawd, after all the other stuff around it got broken, the cupholder survived? Usually that'* the _first_ thing to break; in fact the dealer went ahead and pre-broke mine for my convenience, the day before I picked it up (and replaced it as part of the written terms of sale).
acg_ssei is offline   Reply With Quote
Old 06-26-2003, 01:04 PM   #9
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Jun 2003
Location: Minneapolis, Minnesota
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
TDS-94SSEi is on a distinguished road
Default

Quote:
Originally Posted by acg_ssei

Ohmigawd, after all the other stuff around it got broken, the cupholder survived? Usually that'* the _first_ thing to break; in fact the dealer went ahead and pre-broke mine for my convenience, the day before I picked it up (and replaced it as part of the written terms of sale).
I can see how this part would be succeptible to breakage. I guess we will be sure not togrow too attached to that cupholder!!!! LOL!

I did see a writeup in the tech info that looked like it might help with the console. I didn't read it too close yet, though.
TDS-94SSEi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mechanical question - 2000 SLE Bonne IceWeasel 2000-2005 4 05-03-2008 09:32 AM
Not mechanical but has to do with my Bonne... Pearl_bonnie02 General GM Chat 9 07-03-2007 06:27 PM
1995SE problems and future concerns?? davyboy 1992-1999 7 09-01-2004 09:07 PM
Concerns.... andy Oldsmobile 3 11-04-2003 01:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:37 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.