Low airflow from dash vents - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-27-2003, 10:33 AM   #1
Senior Member
Posts like a 4 Banger
Thread Starter
 
Join Date: Dec 2002
Location: Charlotte NC
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Brian95Blown is on a distinguished road
Default Low airflow from dash vents

OK. I've checked the vents and they are switched to only blow from the mid. no air comes out the top and just a tiny bit comes out the floor. It just doesn't blow well. The motor is turning fast but not muck air seems to come out. I pulled the Blower Controller out but there is no blockage over the Evaporator core. The vacuum canister is also holding. WTF?
Brian95Blown is offline   Reply With Quote
Old 06-27-2003, 11:06 AM   #2
Senior Member
True Car Nut
 
Join Date: May 2002
Location: Edmonton, AB Canada
Posts: 2,621
Thanks: 0
Thanked 0 Times in 0 Posts
DeathRat is on a distinguished road
Default Re: Low airflow from dash vents

Quote:
Originally Posted by Brian95Blown
OK. I've checked the vents and they are switched to only blow from the mid. no air comes out the top and just a tiny bit comes out the floor. It just doesn't blow well. The motor is turning fast but not muck air seems to come out. I pulled the Blower Controller out but there is no blockage over the Evaporator core. The vacuum canister is also holding. WTF?
Check for a vacuum leak first. Then physically check the blend doors manually for proper operation. Look for any bent or kinked cables too while under there.
I'm assuming that this >>>> http://www.bonnevilleattitude.com/fo...f2f72a7f2bbac1 has already been tried too?
DeathRat is offline   Reply With Quote
Old 06-27-2003, 02:37 PM   #3
Junior Member
Posts like a Ricer Type-R
 
Join Date: Apr 2003
Location: Minnesota
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
dspman67 is on a distinguished road
Default

I am having the same problem as listed above as well. Is this evap clean for all Bonnes, mine is a 92 SE without the Automatic Climate Control.
dspman67 is offline   Reply With Quote
Old 06-27-2003, 02:42 PM   #4
Senior Member
Certified GM nut
 
Join Date: Apr 2003
Location: Davison,Michigan
Posts: 1,867
Thanks: 0
Thanked 0 Times in 0 Posts
russianpolarbear is on a distinguished road
Default

Maybe you should pull your blower motor off and see if there is a brake in it. Sounds like a likely suspition
russianpolarbear is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Weird A/C Airflow Problem marquette97 1992-1999 12 08-19-2006 01:48 PM
MAF/Mass Airflow Sensor Falcon123 1992-1999 6 09-06-2005 11:40 PM
A/C problem ... Airflow decreases under acceleration JCurtis 1992-1999 15 07-08-2005 11:57 AM
ac airflow Dan2003526 1987-1991 5 03-25-2005 01:13 AM
A/C airflow question tonyg 1992-1999 5 06-15-2004 02:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.