Loud POP sound and sudden loss of steering support? Any Advice please? - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-10-2011, 10:57 PM   #1
Senior Member
Posts like a Supercharger
Thread Starter
 
viniepooh's Avatar
 
Join Date: Dec 2010
Location: MIchigan
Posts: 177
Thanks: 0
Thanked 1 Time in 1 Post
viniepooh is on a distinguished road
Default Loud POP sound and sudden loss of steering support? Any Advice please?

Hello there,
unfortunately for myself, its me again, writing here asking for advice. This time again my 1996 SSEi giving me problems.
Started the car up, gassed it up to 2000rpm and heard loud POP sound under the hood, after what car stalled. I didn't notice nothing else at first, try ed starting it up and had hard time starting was hesitating, had to help it w/gas pedal at first until it picked up. Once it was up was j/as it was before, except the fact that i was in garage and was suppose to drove out of it and noticed that i lost full hydraulic power steering support. steering wheel basically was all manual. Question to you all: what happen? Therese no powering fluids anywhere on floor or around the car, the car starts j/as it was before, makes no noses (in terms of power steering pump gears or what not). Please advice. Thank you
viniepooh is offline   Reply With Quote
Old 03-10-2011, 11:00 PM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Did you loose the serp belt?
Danthurs is offline   Reply With Quote
Old 03-10-2011, 11:04 PM   #3
Senior Member
Posts like a Supercharger
Thread Starter
 
viniepooh's Avatar
 
Join Date: Dec 2010
Location: MIchigan
Posts: 177
Thanks: 0
Thanked 1 Time in 1 Post
viniepooh is on a distinguished road
Default

Dan, sup buddy, thks for quick come back, i didnt even got a chance to leave the comp. No man, belt is on, its spinning, nothing is odd, but that pop sound and no steering assist. not even pump making weird noises, all quiet, as it was before.
viniepooh is offline   Reply With Quote
Old 03-10-2011, 11:10 PM   #4
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Well, I guess it'* possible the pump went out. I've not heard of any racks going out.
Danthurs is offline   Reply With Quote
Old 03-10-2011, 11:51 PM   #5
Member
Posts like a V-Tak
 
99bonnefan's Avatar
 
Join Date: Sep 2009
Posts: 61
Thanks: 0
Thanked 0 Times in 0 Posts
99bonnefan is on a distinguished road
Default

Broken shaft on pump? Used to see it a lot on gm pickups.
99bonnefan is offline   Reply With Quote
Old 03-10-2011, 11:54 PM   #6
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Kind of what I was thinking. If the rack isn't getting power assist, then the pumps not working.
Danthurs is offline   Reply With Quote
Old 03-10-2011, 11:58 PM   #7
Senior Member

True Car Nut
 
sseidriver97's Avatar
 
Join Date: Mar 2010
Location: Portage mi
Posts: 7,124
Thanked 3 Times in 3 Posts
sseidriver97 is on a distinguished road
Default

It is very possible i had a ps pump shaft snap on my very first truck
sseidriver97 is offline   Reply With Quote
Old 03-11-2011, 12:53 AM   #8
Senior Member
True Car Nut
 
rjolly87's Avatar
 
Join Date: Jun 2003
Location: Las Cruces, NM
Posts: 6,857
Thanked 298 Times in 246 Posts
rjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant futurerjolly87 has a brilliant future
Default

Call me crazy, but did you happen to make sure that not only the rack is still mounted properly, but the subframe didn't drop as well. I have heard similar symptoms that ended up with a serious issue.
rjolly87 is offline   Reply With Quote
Old 03-11-2011, 12:57 AM   #9
Senior Member

True Car Nut
 
sseidriver97's Avatar
 
Join Date: Mar 2010
Location: Portage mi
Posts: 7,124
Thanked 3 Times in 3 Posts
sseidriver97 is on a distinguished road
Default

Usually when the sub frame drops it drops far enough for the intermediate shaft to disconnect and result in a wheel that spins with no stopping ask me how i know have had two cars do this
sseidriver97 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
loud pop when put in reverse and wheel wobble after new axle eltatertoto Buick 7 05-31-2014 09:11 PM
Sudden loss of power at speed norms_bonne Pontiac Bonneville 5 01-10-2012 05:42 PM
sound no sound Advice SSEIVILLE Audio (and aftermarket electronics) 7 04-26-2010 10:39 PM
Loud Pop when accelerating. pontiacandryan 1992-1999 2 09-12-2009 06:53 PM
Loud Pop in the dash when outside temperature is cool. bonnie90se 1987-1991 16 12-21-2006 02:13 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.