Intermittant "Low Coolant" light. - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 06-26-2004, 08:17 PM   #1
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Jun 2004
Location: West Liberty, OH
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
jmark is on a distinguished road
Default Intermittant "Low Coolant" light.

Hi all,

So far you guys have been able to help me with 2 nagging problems with my '93 Bonne SSE. Here'* a new one...

I get an intermittant "Low Coolant" light displayed in the car info display. My temp is normal, just over 200. It happens mostly in the summer when I have the A/C on, when stopping or accelerating from a stop. However it has happened in the winter too, and just driving down the road regardless of season. I've checked antifreeze level several times, now I just kind of blow it off.... Is there something easy to fix here???

Thanks again for your help.

jmark
jmark is offline   Reply With Quote
Old 06-27-2004, 03:17 AM   #2
Senior Member
True Car Nut
 
Join Date: Jun 2003
Location: Purgatory
Posts: 6,313
Thanks: 0
Thanked 0 Times in 0 Posts
PontiacDad is on a distinguished road
Default

Well on the series 2 the coolant level sensor is located on the passenger side of the rad about half way down. Check the connections and maybe replace the sensor.

Have a look, hope it helps?
PontiacDad is offline   Reply With Quote
Old 06-27-2004, 03:37 AM   #3
Member
Posts like a V-Tak
 
Join Date: Jun 2004
Location: Herrin, South Illinois
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Geez SSEi is on a distinguished road
Default

just a thought mark, Have you flushed your system? Iv'e seen sludge build up that was bad enough to foul sensors, but usually clogged the thermostat first.
Geez SSEi is offline   Reply With Quote
Old 06-29-2004, 12:14 AM   #4
Senior Member
True Car Nut
 
Join Date: Sep 2002
Posts: 3,392
Thanks: 0
Thanked 0 Times in 0 Posts
fuddyduddy121 is on a distinguished road
Default

Yes, sounds like a dirty sensor in the radiator.
fuddyduddy121 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1999 Century - "Low Coolant" light Tearitup Buick 3 08-09-2012 09:14 PM
Coolant Leak + Intermittant PO128 RJGill84 2000-2005 5 12-23-2007 11:27 AM
Intermittant code 41, and check engine light. Timothy's Buick 1987-1991 2 11-02-2005 09:15 PM
Intermittant Low Coolant ??? Drifter420 1992-1999 5 09-24-2002 09:55 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.