i think my transmission is T.K.O - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 11-02-2009, 12:32 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2009
Location: laurel, Maryland
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
savage_973 is on a distinguished road
Default i think my transmission is T.K.O

car starts norman
reverses normal
drives slugish like you hear the reving but im not really moving yet
then it starts to move faster and changes gears hard
when i was on the highway it wouldnt change gears at all i went from 30 to 90 with out the rpm'* moving down (showing i've changed gears)
transmission fluid smells burnt

need some answers plz thank u......
oh yea i purchased a 2000 dodge intrepid and its idling rough and is making some clicking sound.....
the entire car shakes when in park...
it drives good...
but then smoke comes up from under the oil cap......
the oil light flickers....
can anyone help with that also
or email me @ [email protected]
savage_973 is offline   Reply With Quote
Old 11-02-2009, 12:35 AM   #2
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

What year is the car? Could be a plugged filter. I would start there.
Danthurs is offline   Reply With Quote
Old 11-02-2009, 12:45 AM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Apr 2009
Location: laurel, Maryland
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
savage_973 is on a distinguished road
Default

its a 97 ssei... i was told that the trans pan was dented so i would have to replace that to change the filter then a code came up for trans shift selaniods????
savage_973 is offline   Reply With Quote
Old 11-10-2009, 08:08 AM   #4
Senior Member
Posts like a 4 Banger
 
PaulDFixr's Avatar
 
Join Date: Sep 2005
Location: Budd Lake, NJ
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
PaulDFixr is on a distinguished road
Default

"Dented" trans pan doesn't exactly describe the damage adequately. If it is really mushed, it likely tweaked something inside. Just a little denting usually isn't problematic as there is some clearance. You're gonna have to take it off to see if there'* any visible damage... but I understand your dilemma if you're not one to do this job yourself in the garage. The shop might get it apart and not be able to get it back to even its currently poor running condition... without a rebuild or new/used trans swap. I've been there too.
My bonnie spun a crank bearing driving it home from the guy I bought it from, and that behaved much like your other vehicle is behaving. However, I could start and run the car for a few minutes, then the engine would bog down and start to smoke, and I couldn't keep it running. It doesn't sound like yours has quite the same symptoms... try a compression test first since the idle is so rough.
PaulDFixr is offline   Reply With Quote
Old 11-10-2009, 08:14 AM   #5
Retired Senior Admin

Expert Gearhead
 
Danthurs's Avatar
 
Join Date: May 2006
Location: Sheboygan Wisconsin
Posts: 29,661
Thanks: 0
Thanked 16 Times in 13 Posts
Danthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to allDanthurs is a name known to all
Default

Check the car over for vacuum leaks. I've seen that code come up with a large vacuum leak. Check all lines including the EGR tubes.
Danthurs is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle, Foul rotten egg smell, Think 02? Think again. SSEBONNE4EVA General GM Chat 6 01-20-2008 05:18 PM
I think I might have transmission problems. Knock on wood johnny rockit 1992-1999 2 07-02-2007 12:21 PM
transmission probem I think jwagner 2000-2005 6 09-03-2006 08:17 PM
Transmission whine/ Found the issue I think/UPDATE Mike 1992-1999 43 07-17-2006 04:45 PM
Do you think my left (rear) transmission mount is bad? zuluhead 2000-2005 0 11-06-2005 11:41 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.