Heres my troubles again - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-10-2005, 09:43 PM   #1
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Posts: 7,262
Thanks: 0
Thanked 0 Times in 0 Posts
ssesc93 is on a distinguished road
Default Heres my troubles again

I am not happy with my performance. This is a 2 part thread. No. 1

When I am driving and I am on the expressway to pass, sometimes I can get some really nice performance when I give it WOT. Then again I ccan try it again after a few minutes and the car lugs at WOT. Whats the matteer with this? Is it the trans or is it the coupler?
ssesc93 is offline   Reply With Quote
Old 02-10-2005, 09:45 PM   #2
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Posts: 7,262
Thanks: 0
Thanked 0 Times in 0 Posts
ssesc93 is on a distinguished road
Default

part 2

I am also experiancing a noise every time i hit a bump. Its a rattle. I am wondering if this is my ball joints, tie rods, stabilizer pins? I need to get this replaced what ever it is.
ssesc93 is offline   Reply With Quote
Old 02-10-2005, 09:46 PM   #3
Senior Member
Certified Car Nut
 
Join Date: Oct 2003
Posts: 19,756
Thanks: 0
Thanked 0 Times in 0 Posts
1993 SLE is on a distinguished road
Default

Quote:
Originally Posted by ssesc93
part 2

I am also experiancing a noise every time i hit a bump. Its a rattle. I am wondering if this is my ball joints, tie rods, stabilizer pins? I need to get this replaced what ever it is.
could be the endlinks
1993 SLE is offline   Reply With Quote
Old 02-10-2005, 09:46 PM   #4
Senior Member
True Car Nut
 
Join Date: Feb 2004
Location: Pennsylvania
Posts: 5,177
Thanks: 0
Thanked 0 Times in 0 Posts
Twister97 is on a distinguished road
Default

So the noise is defenately coming from underneath the car?
Twister97 is offline   Reply With Quote
Old 02-10-2005, 09:52 PM   #5
Junior Member
Posts like a Ricer Type-R
 
Join Date: Aug 2002
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
willwren is on a distinguished road
Default Re: Heres my troubles again

Quote:
Originally Posted by ssesc93
I am not happy with my performance. This is a 2 part thread. No. 1

When I am driving and I am on the expressway to pass, sometimes I can get some really nice performance when I give it WOT. Then again I ccan try it again after a few minutes and the car lugs at WOT. Whats the matteer with this? Is it the trans or is it the coupler?
The coupler has absolutely no effect whatsoever on performance. Try belt slip.

Moving this to 92-99.
willwren is offline   Reply With Quote
Old 02-10-2005, 10:03 PM   #6
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Posts: 7,262
Thanks: 0
Thanked 0 Times in 0 Posts
ssesc93 is on a distinguished road
Default

whats a belt slip?
ssesc93 is offline   Reply With Quote
Old 02-10-2005, 11:20 PM   #7
Senior Member
Posts like a Northstar
 
Join Date: Apr 2004
Location: Minneapolis, MN
Posts: 566
Thanks: 0
Thanked 0 Times in 0 Posts
CSFiend is on a distinguished road
Default

I agree, belt slip is a possibility. Can be caused by a failing belt tensioner or a belt that is slipping (hence the name...). The first thing (and cheapest, and probably the easiest to replace) to check is the swaybar links.
CSFiend is offline   Reply With Quote
Old 02-11-2005, 03:44 AM   #8
Senior Member
Certified Car Nut
 
Join Date: Jun 2003
Posts: 15,928
Thanks: 0
Thanked 0 Times in 0 Posts
BonneMeMN is on a distinguished road
Default

You sure you're not out of the powerband on the freeway when you're going WOT?

Belt slip (you did change the belt didn't you ) could be it, maybe heat soak and a bad coil?
BonneMeMN is offline   Reply With Quote
Old 02-11-2005, 09:25 AM   #9
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Posts: 7,262
Thanks: 0
Thanked 0 Times in 0 Posts
ssesc93 is on a distinguished road
Default

I kust said I dont know what a belt slip is. I will get it checked out.
ssesc93 is offline   Reply With Quote
Old 02-11-2005, 11:31 AM   #10
Senior Member
True Car Nut
Thread Starter
 
Join Date: May 2003
Posts: 7,262
Thanks: 0
Thanked 0 Times in 0 Posts
ssesc93 is on a distinguished road
Default

what is a belt slip? What are sway bars? I dont know these things.
ssesc93 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake pedal low again and again and again NMP1 GMC/Chevrolet Truck/SUV 2 07-17-2015 11:56 AM
alright boys heres my problem greenmoose92 1992-1999 15 11-03-2003 05:30 PM
Heres Mine....(lots o pics) UPDATED Aug21st! FiReDeViL Your Ride: GM Pictures & Videos 16 08-22-2003 11:06 AM
Heres Some Pics of G2 gold Calipers!w/ new RSM rotors & Nytro67 Your Ride: GM Pictures & Videos 24 06-11-2003 11:42 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.