HELP PLEASE..... - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 05-06-2003, 12:50 PM   #11
Senior Member
Posts like a Turbo
 
Join Date: May 2003
Location: Oklahoma
Posts: 359
Thanks: 0
Thanked 0 Times in 0 Posts
Kuhl is on a distinguished road
Default

Did you check the computer for some codes?
Kuhl is offline   Reply With Quote
Old 05-06-2003, 03:59 PM   #12
Senior Member
Posts like a Corvette
 
Join Date: Jan 2002
Location: Ontario
Posts: 1,253
Thanks: 0
Thanked 0 Times in 0 Posts
Tamara is on a distinguished road
Default

Quote:
Originally Posted by salserin69
Basically when I start driving, once I am accelerating it hessitates (jerks) like not getting fuel into the injectors or something, the mechanic he said he would recomend getting a new fuel filter to start and then go from there, the part I didn't like was go from there...
$$$$$$ if you get my drift..
Since its my daily driver and I depend on it I want it done right and not second guessing.
spark plugs and spark plug wires is probably where you should start. When were they last replaced? if recent, what are they? I had this same problem last year and thought it was fuel filter as well. The problem normally occurs around 80kmph or going into overdrive for me....too lazy to convert that to miles for you right now.
Tamara is offline   Reply With Quote
Old 05-06-2003, 04:14 PM   #13
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2003
Location: Ocala, Fl
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
salserin69 is on a distinguished road
Default

I had the spark plugs replaced 3 weeks ago and I had platinum placed.....I am going to another mechanic so he can run in in the computer for codes.....THANKS
salserin69 is offline   Reply With Quote
Old 05-06-2003, 04:39 PM   #14
Senior Member
Expert Gearhead
 
Join Date: Dec 2002
Location: Mississauga, Ontario
Posts: 20,892
Thanks: 0
Thanked 1 Time in 1 Post
Jim W is on a distinguished road
Default

80 kph is about 50 mph...rough conversion
Jim W is offline   Reply With Quote
Old 05-06-2003, 07:47 PM   #15
Senior Member
Posts like a Corvette
 
Join Date: Jan 2002
Location: Ontario
Posts: 1,253
Thanks: 0
Thanked 0 Times in 0 Posts
Tamara is on a distinguished road
Default

Quote:
Originally Posted by salserin69
I had the spark plugs replaced 3 weeks ago and I had platinum placed.....I am going to another mechanic so he can run in in the computer for codes.....THANKS

BOSH platinum? I've heard some people have a lot of problems with these....you have a Series II right?? I have the same car as you (pretty much- 95 with Series II) and I have bosh platinum + 4s and haven't had a problem...however, some people will attest that that can be your problem if that'* what you are running..
Tamara is offline   Reply With Quote
Old 05-07-2003, 09:12 AM   #16
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2003
Location: Ocala, Fl
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
salserin69 is on a distinguished road
Default

Well I can see that my weekend is full of fun fun fun, fuel filter, spark plugs and wires for a start....Thanks

As for my mechanic, he is out of here,
I'll let you know with the results later on...
salserin69 is offline   Reply With Quote
Old 05-07-2003, 06:27 PM   #17
Burgundy_Boat
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by salserin69
Well I can see that my weekend is full of fun fun fun, fuel filter, spark plugs and wires for a start....Thanks

As for my mechanic, he is out of here,
I'll let you know with the results later on...
I might be missing something here, but what did your mechanic do?
  Reply With Quote
Old 05-08-2003, 08:32 AM   #18
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2003
Location: Ocala, Fl
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
salserin69 is on a distinguished road
Default

He took the car for a test drive and then said that it could be this or it could be that....so the first thing I would do is the fuel filter. I believe that he was more interested on the trip his friend was planing on....They were going to Palm Beach....so it wasn't as important to him as it was for me.... so now he can look for someone else to rip off..
salserin69 is offline   Reply With Quote
Old 05-08-2003, 04:07 PM   #19
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Mar 2003
Location: Ocala, Fl
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
salserin69 is on a distinguished road
Default

Well I could not wait for the weekend and last night I decided to pull my Bonneville Tech Manual, and step by step I replaced the fuel filter.... very easy once you do some reading and follow the pictures

This morning it was the first surprise on the road where I had no jerking while accelerating.... I am still going to take it to this other mechanic to connect the computer and see what codes will pull.....also its power steering pump replacement saturday morning.... any sugestions on what not to do....
salserin69 is offline   Reply With Quote
Old 05-08-2003, 07:23 PM   #20
Senior Member
Posts like a Turbo
 
Join Date: Mar 2003
Location: Indianapolis, Indiana
Posts: 311
Thanks: 0
Thanked 0 Times in 0 Posts
along is on a distinguished road
Default Fuel Pump and Bosch Plugs

Hey there, just a few comments about Fuel pumps and Bosch plugs.

My car was running poorly and I spent good money about 6 months ago on Bosch premium plugs and new wires. The were due to be changed anyway. My cars performance didnt change much.

Well, recently, my mechanic changed my plugs to another brand (AC Delco or Champion, I forget). He said that the Bosch were my problem and charged me about $70 for plugs and labor. Anyway, there was no change. My mechanic says he doesnt like Bosch parts on Pontiacs, but I dont have enough mechanical experience to argue with him.

The other thing I wanted to comment on was my fuel pump. To answer someones question about losing power on turns, I recently replaced the fuel pump and filters in my 92SSE.

Everytime the tank got below 1/2 a tank of gas, any sharp turns or sudden braking would cause sudden loss of power. Sometimes the car would even stall on braking hard. It did idle ok though and ran fine as long as I had more than 1/2 a tank of gas.

The new fuel pump fixed it, bad news was that it isnt easy to change, its in the fuel tank. I didnt go with a cheap one, but got the OEM pump, hopefully it will last longer.

Andrew
92 SSE
97 SSEi
along is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
ANYBODY please, please help, car alarm driving me NUTS aodessey 1987-1991 17 11-29-2008 02:05 PM
Please, please PLEASE! willwren Lounge 20 03-26-2008 01:16 PM
HELP HELP HELP, EXPERTS PLEASE !! statusplease 1992-1999 8 03-15-2008 06:49 PM
ELECTRICAL PROBLEMS< PLEASE HELP, PLEASE jamesdean26hfx 1992-1999 3 09-20-2004 07:45 PM
The WP is driving me crazy, please....oh...please help me! valerka 1992-1999 2 07-28-2004 11:15 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.