Help!!!!! car wont go over 45 mph - Page 2 - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 02-04-2012, 11:20 AM   #11
Senior Member
Posts like a Turbo
 
SilverSleeper8704's Avatar
 
Join Date: Jan 2010
Location: "Upstate" NY. Where cows outnumber people
Posts: 441
Thanked 1 Time in 1 Post
SilverSleeper8704 is on a distinguished road
Default

Sounds like you're not getting 3rd, maybe 4th (OD).

When did the fans stop working? Same time this started?
Any other weird electronic symptoms? Anything at all?
How are the terminals on the battery, are your power and ground wires clean and free of corrosion? You haven't by any chance had to get a jump start on the car lately, have you?

Sometimes, a bunch of seemingly random electronic part failures can be traced back to bad batteries, battery wires, or the connections at the ECM/PCM. The PCM depends on a good solid ground to make a lot of things work right. If the ground or power to the PCM is even a bit sketchy, a lot of things can seem to go nuts at once.
I believe your PCM controls the fans. If you put your HVAC controls into defog mode (or command A/C from it), the compressor should kick on, and the fans should turn on, no matter what temp it is outside.
I'd start with checking the battery wires, and cleaning the terminals. Go through the PCM connector and check the pins for any sign of corrosion. Unplug the battery and clean up the PCM connector.

This is all just generalized stuff. I don't have much experience with this year, or the electronics specifically. But its somewhere to start. If none of those things help, maybe some of the gurus with more experience with cars like yours can be of more help.
SilverSleeper8704 is offline   Reply With Quote
Old 02-04-2012, 11:30 AM   #12
Senior Member
Posts like a Northstar
 
Join Date: Oct 2009
Location: Boston Mass
Posts: 684
Thanks: 0
Thanked 0 Times in 0 Posts
sgp358 is on a distinguished road
Default

So if you manually shift it, do the RPM'* go crazy when you hit "D"??

It sounds like you have no 3rd or 4th, but it'* hard for me to verify anything without driving the car. I doubt that it is electronic as it appears from your description that it is making the shift.
sgp358 is offline   Reply With Quote
Old 02-04-2012, 03:27 PM   #13
Senior Member
Posts like a Turbo
 
Savagecowboy_69's Avatar
 
Join Date: Jun 2009
Location: Mooresville, N.C.
Posts: 220
Thanks: 0
Thanked 0 Times in 0 Posts
Savagecowboy_69 is on a distinguished road
Default

check ur maf
Savagecowboy_69 is offline   Reply With Quote
Old 02-04-2012, 03:39 PM   #14
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Sep 2011
Location: jermyn pa
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
jamesdean674 is on a distinguished road
Default

5 weeks ago the car wouldint start it had power but know klicking nothing so i played with the relays on the firewall and it started right up.week ago my oil pressure sensor on the side of the engine the back blew out and leaked all the oil out when that happened the car wouldint go over 45 mph so i kept pulling over and puting oil in it to make it home i thought it was a limp home thing because it was shooting the oil out so i thought thats why the car wouldint go over 45 mph i thought it was a saftey thing because of the oil problem.thats win this started with the speed problem
jamesdean674 is offline   Reply With Quote
Old 02-04-2012, 03:41 PM   #15
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Sep 2011
Location: jermyn pa
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
jamesdean674 is on a distinguished road
Default

whats maf
jamesdean674 is offline   Reply With Quote
Old 02-04-2012, 03:57 PM   #16
Junior Member
Posts like a Ricer Type-R
Thread Starter
 
Join Date: Sep 2011
Location: jermyn pa
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
jamesdean674 is on a distinguished road
Default

weres the pcm located!!
jamesdean674 is offline   Reply With Quote
Old 02-06-2012, 09:25 AM   #17
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

Not being a jerk here. Think about this post from our standpoint. You are giving us zero information that we are asking about and leaving out stuff that may be important. I'm frustrated...

Free help requires two way communication. Please, read what we post and respond directly to each question. That'll help fix this much quicker.

The only thing back by the oil pressure sensor is the VSS or vehicle speed sensor for the transmission. However if your speedo is working, then I doubt it'* bad.

Are any codes present?
Does the car studder?
What rpm are you running at 45mph?
Please stop obsessing over the relays. Search on my name and fan override if you are looking for pictures of the relays and their function. However I can tell you, this issue has nothing to do wtih a relay.
BillBoost37 is offline   Reply With Quote
Old 02-26-2012, 05:23 PM   #18
Junior Member
Posts like a Ricer Type-R
 
Join Date: Feb 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
brickhouse5256 is on a distinguished road
Default

did you try a speed sensor
brickhouse5256 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
SSEi wont rev over 4000 RPM HELP! chewy_mxer 2000-2005 21 10-02-2009 10:27 AM
1994 bonneville-wont start, wont run backwoodsfab 1992-1999 0 10-09-2008 07:27 PM
CAR JUST DIED GOING 60 MPH AND WILL NOT RESTART CMUNDEN 2000-2005 18 03-31-2008 12:40 PM
Me Wont ooo ooo Me Wont!!! bandit Your Other Rides: Pics & Videos 4 06-18-2006 02:09 AM
Shake at over 70 mph '01 MA Bonneville General GM Chat 12 03-09-2005 10:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.