headlight switch and engine problems - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-26-2007, 02:09 AM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
marz is on a distinguished road
Default headlight switch and engine problems

ok i'm needing some infinite wisdom. first my headlight switch works until you try to dim it then it goes dark, for about a 1/8th turn,then it comes back on and dims just fine. also my sentinel doesnt work, heres the catch its the 3rd light switch to do the exact same thing. including one that came out of a car where it worked fine. secondly my bonne is fine until i get into the gas pretty well then it falls on its face, after which it then takes off after about 2 seconds or so. the injectors and fpr are good as is both the tps and map sensor,also there is no vaccum leaks, where do i go next? also the trans shifts a little to early. thanks
marz is offline   Reply With Quote
Old 07-26-2007, 08:45 AM   #2
Senior Member
True Car Nut
 
Join Date: Dec 2003
Location: Corn Fields, IN
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
John Deere Boy is on a distinguished road
Default

Hello. Please start a seperate topic in the Everything Electronic forum for the dimmer switch.

For the engine, does this hesitation happen when you're sitting still and go to take off, or when you're cruising and go to pass, or both? I would start by cleaning the throttlebody. That cured the hesitation i had while starting out from a stop.
John Deere Boy is offline   Reply With Quote
Old 07-26-2007, 09:04 AM   #3
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

When was your last tune up of plugs and wires at a minimum?
BillBoost37 is offline   Reply With Quote
Old 07-26-2007, 10:50 AM   #4
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
marz is on a distinguished road
Default

it happens in passing and crusing and the plugs and wires are about 3 months old.
marz is offline   Reply With Quote
Old 07-27-2007, 02:32 AM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
marz is on a distinguished road
Default

and now its getting about 13 miles to the gallon.
marz is offline   Reply With Quote
Old 07-27-2007, 12:26 PM   #6
DINOSAURUS BOOSTUS

Expert Gearhead
 
BillBoost37's Avatar
 
Join Date: Mar 2005
Location: Enfield, CT
Posts: 41,391
Thanks: 0
Thanked 0 Times in 0 Posts
BillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of lightBillBoost37 is a glorious beacon of light
Default

That would indicate that it is running rich and or has an exhaust restriction.

Any odd smells coming from the car lately... say along the smell of rotten eggs? Any rattling coming from under the car? Both os these questions point at diagnosing the catalytic converter.
BillBoost37 is offline   Reply With Quote
Old 07-28-2007, 01:35 AM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
marz is on a distinguished road
Default

thats a good idea, i dont have a smell at all but i do have a rattle ill search in the morning! i did however replace the front o2 sensor and it seems to help quit drastically, im up to about 18 miles to the gallon now but it still hesitates. to everyone who reads this everyone here that tells you bosh o2 sensors dont work they know what there talking about spend the extra 10 bucks and by a ac delco or delphi.
marz is offline   Reply With Quote
Old 07-28-2007, 09:51 PM   #8
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
marz is on a distinguished road
Default

how would i go about testing the maf sensor? would this possibly cause this issue?
marz is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
95 Bonne Headlight switch and connector sodbuster65 Everything Electrical & Electronic 8 07-24-2010 06:52 AM
Headlight switch and harness Dachipsta Everything Electrical & Electronic 4 06-18-2007 12:11 PM
Headlight Switch Differences 95 and 96-99 (w/ Twilight) BillBoost37 Everything Electrical & Electronic 2 11-26-2005 09:46 PM
Headlight switch and connector meltdown....HELP BillBoost37 Everything Electrical & Electronic 10 04-13-2005 04:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:02 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.