Grandmas car needs help> Case Closed - GM Forum - Buick, Cadillac, Chev, Olds, GMC & Pontiac chat


1992-1999 Series I L27 (1992-1994 SE,SLE, SSE) & Series II L36 (1995-1999 SE, SSE, SLE) and common problems for the Series I and II L67 (all supercharged models 92-99) Including Olds 88's, Olds LSS's and Buick Lesabres Please use General Chat for non-mechanical issues, and Performance and Brainstorming for improvements.

Reply
 
 
 
Thread Tools Search this Thread
Old 03-08-2008, 05:38 PM   #1
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
alwaysomething is on a distinguished road
Default Grandmas car needs help> Case Closed

My grandmas 95 Se needs help. Here is what I know, it will start only after pumping the gas but it stalls and won't keep running. It puffs out black smoke and smells like gas. I unplugged the MAF and it did not even fire. Is it a sensor? which one?
alwaysomething is offline   Reply With Quote
Old 03-08-2008, 07:07 PM   #2
Senior Member
True Car Nut
 
Join Date: Jul 2006
Location: Granville, Ohio ~NEBF '07 Survivor~
Posts: 5,001
Thanks: 0
Thanked 0 Times in 0 Posts
petraman is on a distinguished road
Default

IIRC, if your MAF sensor is in good health, the stored values from previous runs would be set as defaults, therefore allowing you to start the car. All signs point to a bad MAF, but I've never heard of a car doing something like that... Sounds like it'* running REALLY rich, and I wouldn't run it like that. There'* a whole slew of things that can go wrong when you do...
petraman is offline   Reply With Quote
Old 03-08-2008, 07:13 PM   #3
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
alwaysomething is on a distinguished road
Default Grandmas car needs help

I thought MAF also but before she spends $150 I hope to pin it down.
alwaysomething is offline   Reply With Quote
Old 03-08-2008, 07:18 PM   #4
Senior Member
True Car Nut
 
Join Date: Jul 2006
Location: Granville, Ohio ~NEBF '07 Survivor~
Posts: 5,001
Thanks: 0
Thanked 0 Times in 0 Posts
petraman is on a distinguished road
Default

150? Email Ed Morad...
Ed at MoradPartsCompany dot com (replace at with @ and dot with . , no spaces...)

He should have what you're looking for. I just bought a MAF from him for about half that
petraman is offline   Reply With Quote
Old 03-08-2008, 07:43 PM   #5
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
alwaysomething is on a distinguished road
Default Grandmas car needs help

is that for a new one?
alwaysomething is offline   Reply With Quote
Old 03-08-2008, 07:48 PM   #6
Senior Member
True Car Nut
 
Join Date: Jul 2006
Location: Granville, Ohio ~NEBF '07 Survivor~
Posts: 5,001
Thanks: 0
Thanked 0 Times in 0 Posts
petraman is on a distinguished road
Default

No, used, but he'* one of the most trusted vendors on this site. I haven't heard of one problem with them, and I've bought a transmission and a MAF sensor from him. He tests them and checks the car it came from for codes before shipping them out.
petraman is offline   Reply With Quote
Old 03-08-2008, 07:51 PM   #7
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
alwaysomething is on a distinguished road
Default Grandmas car needs help

Ok I just hope that is the problem. Any other input folks?
alwaysomething is offline   Reply With Quote
Old 03-08-2008, 11:18 PM   #8
Senior Member
True Car Nut
 
Join Date: Jul 2004
Location: Grand Rapids, Mi
Posts: 5,656
Thanks: 0
Thanked 0 Times in 0 Posts
Archon is on a distinguished road
Default

Sounds like the exact symptoms that my son had with his '99 Grand Prix. Disconnecting the MAF gave the same result of not starting at all. Replacing the MAF cured the problem. Any codes set?
Archon is offline   Reply With Quote
Old 03-09-2008, 12:04 AM   #9
Junior Member
 
Join Date: Sep 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
gmman is on a distinguished road
Default

just another idea. had what seem to be a flooding problem. black smoke and would not stay running. turned out to be coolant sensor. not the one that supplies the temp gauge but the one that tells computer engine temp. sensor was telling computer that it was 0 degrees farenheit when actual outside temp was much higher. fuel injectors were pouring in too much gas.
gmman is offline   Reply With Quote
Old 03-09-2008, 09:44 AM   #10
Member
Posts like a V-Tak
Thread Starter
 
Join Date: Feb 2008
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
alwaysomething is on a distinguished road
Default Grandmas car needs help

We have not checked for codes yet. Thanks everyone
alwaysomething is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Grandmas don't know everything.... Purplehazeir Lounge 4 08-04-2010 02:47 AM
Grandmas car still won't run alwaysomething 1992-1999 1 03-15-2008 10:24 PM
NOMINIATE PEOPLE.....FOR CAR OF THE MONTH...closed Hans Your Ride: GM Pictures & Videos 11 10-11-2007 10:52 PM
CAR OF THE MONTH....CLOSED!!!! Hans Your Ride: GM Pictures & Videos 9 09-19-2007 11:35 PM
MARCH 2007 Car of the Month -- CLOSED FOR SUBMISSIONS Hans Your Ride: GM Pictures & Videos 16 05-09-2007 07:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.